Bug 739479 - [abrt] yum-3.4.3-4.fc16: yummain.py:203:main:AttributeError: 'YumBaseCli' object has no attribute '_depsolving_failed'
Summary: [abrt] yum-3.4.3-4.fc16: yummain.py:203:main:AttributeError: 'YumBaseCli' obj...
Keywords:
Status: CLOSED DUPLICATE of bug 731717
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5570da97efd1a94306d530ee319...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 08:21 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 08:47:46 UTC


Attachments (Terms of Use)

Description Jiri Moskovcak 2011-09-19 08:21:53 UTC
abrt version: 2.0.5.101.gf899
cmdline:        /usr/bin/python /usr/bin/yum update
executable:     /usr/bin/yum
kernel:         3.1.0-0.rc6.git0.0.fc16.x86_64
reason:         yummain.py:203:main:AttributeError: 'YumBaseCli' object has no attribute '_depsolving_failed'
username:       root

backtrace:
:yummain.py:203:main:AttributeError: 'YumBaseCli' object has no attribute '_depsolving_failed'
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 203, in main
:    if base._depsolving_failed:
:AttributeError: 'YumBaseCli' object has no attribute '_depsolving_failed'
:
:Local variables in innermost frame:
:prefix2nd: '       '
:e: NoMoreMirrorsRepoError()
:resultmsgs: [u'failure: repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.']
:lockerr: ''
:args: ['update']
:unlock: <function unlock at 0xf1f848>
:verbose_logger: <logging.Logger object at 0xf1ba10>
:prefix: u'Error: %s'
:base: <cli.YumBaseCli object at 0xf1ba50>
:result: 1
:msg: u'failure: repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.'
:exFatal: <function exFatal at 0xf1f7d0>
:exPluginExit: <function exPluginExit at 0xf1f758>
:exUserCancel: <function exUserCancel at 0xf1f668>
:logger: <logging.Logger object at 0xe32910>
:exIOError: <function exIOError at 0xf1f6e0>
:rpmdb_warn_checks: <function rpmdb_warn_checks at 0xf1f8c0>

comment:
:Ran yum update on F16 and there were no mirrors available. Yum complained a lot and then failed with:
:
:Trying other mirror.
:ftp://mirror.nexicom.net/pub/fedora/linux/development/16/x86_64/debug/repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2: [Errno 14] FTP Error 550 : ftp://mirror.nexicom.net/pub/fedora/linux/development/16/x86_64/debug/repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2 
:Trying other mirror.
:ftp://ftp.osuosl.org/pub/fedora/linux/development/16/x86_64/debug/repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2: [Errno 14] FTP Error 550 : ftp://ftp.osuosl.org/pub/fedora/linux/development/16/x86_64/debug/repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2 
:Trying other mirror.
:ftp://ftp.gtlib.gatech.edu/pub/fedora.redhat/linux/development/16/x86_64/debug/repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2: [Errno 14] FTP Error 550 : ftp://ftp.gtlib.gatech.edu/pub/fedora.redhat/linux/development/16/x86_64/debug/repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2 
:Trying other mirror.
:Error: failure: repodata/b337b238181bd5a9f9d7f7fa9965f7c548d6f95bf9471d94841f692fe8ba03a1-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.

Comment 1 Zdeněk Pavlas 2011-09-19 08:47:46 UTC

*** This bug has been marked as a duplicate of bug 731717 ***


Note You need to log in before you can comment on or make changes to this bug.