Bug 739487 - RFE: support qed format on volume creation
Summary: RFE: support qed format on volume creation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst
Version: 6.2
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 748554
TreeView+ depends on / blocked
 
Reported: 2011-09-19 08:52 UTC by Nan Zhang
Modified: 2011-12-06 16:17 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:17:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1643 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2011-12-06 00:50:36 UTC

Description Nan Zhang 2011-09-19 08:52:43 UTC
Description of problem:
As we know, the lastest qemu-kvm already support qed image format, so virt-manager also needs to support.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-11.el6.x86_64
qemu-kvm-0.12.1.2-2.190.el6.x86_64
virt-manager-0.9.0-6.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start up virt-manager
2. Edit -> Connection Details -> Storage -> New Volume

Actual results:
no qed option in [Format] for volume creation.

Expected results:
qed format could be created and displayed normally.

Additional info:

Comment 2 Cole Robinson 2011-09-22 14:52:45 UTC
We actually store this list in virtinst, so that's where the fix is:

http://git.fedorahosted.org/git?p=python-virtinst.git;a=commit;h=9b38d38851c1b24783ad94655d8cd19cfeb1f011

Comment 4 Cole Robinson 2011-10-13 21:46:42 UTC
Fixed in python-virtinst-0.600.0-4.el6

Comment 7 Huming Jiang 2011-10-19 10:04:07 UTC
Verified with
kernel-2.6.32-197.el6.x86_64
qemu-kvm-0.12.1.2-2.192.el6.x86_64
libvirt-0.9.4-17.el6.x86_64
python-virtinst-0.600.0-5.el6.noarch
virt-manager-0.9.0-7.el6.x86_64

step:
1. Start up virt-manager
2. Edit -> Connection Details -> Storage -> New Volume
  
   qed option is in [Format] list for volume creation.

3. Add a qed format volume to the storage.
  
   qed format could be created ,displayed and deleted normally.

So move the status of this bug to verified.

Comment 8 Cole Robinson 2011-11-07 16:54:48 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 9 errata-xmlrpc 2011-12-06 16:17:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1643.html


Note You need to log in before you can comment on or make changes to this bug.