Bug 739491 - RHEV-H show virtualization hardware is unavailable after register to RHEV-M
Summary: RHEV-H show virtualization hardware is unavailable after register to RHEV-M
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 09:07 UTC by cshao
Modified: 2011-12-06 19:28 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-2.0.2-0.9.git9048c81.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:28:07 UTC


Attachments (Terms of Use)
ovirt.log (28.67 KB, text/plain)
2011-09-19 09:07 UTC, cshao
no flags Details
virtualization hardware is unavailable (23.22 KB, image/jpeg)
2011-09-19 10:19 UTC, cshao
no flags Details
Patch (867 bytes, patch)
2011-09-21 19:13 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description cshao 2011-09-19 09:07:34 UTC
Created attachment 523808 [details]
ovirt.log

Description of problem:
RHEV-H show virtualization hardware is unavailable after register to RHEV-M

Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.17.1.el6

How reproducible:
30%

Steps to Reproduce:
1. Install RHEV-H.
2. Register RHEV-H to RHEV-M.
3. Reboot RHEV-H several times.
  
Actual results:
RHEV-H show virtualization hardware is unavailable after register to RHEV-M

Expected results:
RHEV-H can positively identify virtualization info.

Additional info:

Comment 2 Alan Pevec 2011-09-19 09:32:16 UTC
(In reply to comment #0)
> How reproducible:
> 30%

> 3. Reboot RHEV-H several times.

> Actual results:
> RHEV-H show virtualization hardware is unavailable after register to RHEV-M

That's login screen I assume?
What about Status page in TUI?

Comment 3 cshao 2011-09-19 10:19:12 UTC
Created attachment 523816 [details]
virtualization hardware is unavailable

Comment 4 cshao 2011-09-19 10:20:08 UTC
> That's login screen I assume?
> What about Status page in TUI?

Please see attachment "virtualization hardware is unavailable".

Comment 5 Alan Pevec 2011-09-19 20:05:14 UTC
Connection to libvirtd fails in ovirt-post:
Sep 19 16:07:55 Starting ovirt-post
error: Failed to reconnect to the hypervisor
error: no valid connection
error: Cannot recv data: Connection reset by peer

This might happen in case when vdsmd is restarting libvirt but that should happen only first time vdsmd starts on the node and reconfigures libvirt, not 30% of times...

Comment 6 Mike Burns 2011-09-21 18:35:03 UTC
That doesn't make sense though.  ovirt-post runs in a loop waiting for libvirt to be started.  Even if vdsm does restart libvirt, it should take more than the 100 sec that we wait.  

Also,  vdsmd starts after ovirt-post runs, so it can't be related to that

Comment 7 Alan Pevec 2011-09-21 18:49:36 UTC
Loop waiting is for libvirt-sock-ro to show up
but I didn't spot "Waiting for libvirt to finish initializing..." in the attched log.
More robust would be to loop wait until virsh connect qemu:///system --readonly succeeds.

Comment 8 Mike Burns 2011-09-21 19:13:34 UTC
Created attachment 524266 [details]
Patch

Not sure if this will completely fix the issue, but it shouldn't hurt.  Please move back to Assigned if the problem persists.

Comment 10 Ying Cui 2011-10-13 07:26:20 UTC
Verified this bug on RHEV-H 6.2-20111010.2.el6 build.
Can not meet this bug after registering rhevm.

Comment 11 errata-xmlrpc 2011-12-06 19:28:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.