Bug 739519 - "Command not found: " Error in aeolus-check-services and aeolus-restart-services scripts
Summary: "Command not found: " Error in aeolus-check-services and aeolus-restart-servi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Mike Orazi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 11:10 UTC by Aziza Karol
Modified: 2012-01-26 12:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-07 12:49:53 UTC


Attachments (Terms of Use)

Description Aziza Karol 2011-09-19 11:10:43 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Execute aeolus-check-services and aeolus-restart-services 

[root@dell-pe2850-04 templates]# aeolus-restart-services 

Stoping imagefactory ...
 Success: Stopping imagefactory (via systemctl):  [  OK  ]

Stoping conductor-dbomatic ...
 Success: Stopping conductor-dbomatic (via systemctl):  [  OK  ]

Stoping aeolus-conductor ...
 Success: Stopping aeolus-conductor (via systemctl):  [  OK  ]

Stoping condor ...
 Success: Stopping condor (via systemctl):  [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd (via systemctl):  [  OK  ]

Stoping deltacloud-mock ...
/usr/sbin/aeolus-restart-services:63: command not found: /etc/init.d/deltacloud-mock stop
 FAILURE: 

Stoping deltacloud-ec2-us-west-1 ...
/usr/sbin/aeolus-restart-services:63: command not found: /etc/init.d/deltacloud-ec2-us-west-1 stop
 FAILURE: 

Stoping deltacloud-ec2-us-east-1 ...
/usr/sbin/aeolus-restart-services:63: command not found: /etc/init.d/deltacloud-ec2-us-east-1 stop
 FAILURE: 


  
Actual results:


Expected results:
These commands are no longer needed as we switched to single detlacloud core
so this traces also has to be removed from the  aeolus-check-services and aeolus-restart-services scripts.


Additional info:
Additional info:
[root@dell-pe2850-04 nodes]# rpm -qa  | grep aeolus
aeolus-configure-2.0.2-4.20110916125556git5a94390.fc15.noarch
aeolus-conductor-0.4.0-0.20110916175452git9d14599.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110916175452git9d14599.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110916175452git9d14599.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110914104314gitb6195f6.fc15.noarch
aeolus-all-0.4.0-0.20110916175452git9d14599.fc15.noarch

Comment 1 wes hayutin 2011-09-22 14:04:48 UTC
[root@unused aeolus-conductor]# aeolus-check-services 

Checking mongod ...
 Success: mongod.service - SYSV: Starts and stops the MongDB daemon that handles all database requests.
	  Loaded: loaded (/etc/rc.d/init.d/mongod)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:54 -0400; 15h ago
	Main PID: 5192 (mongod)
	  CGroup: name=systemd:/system/mongod.service
		  └ 5192 /usr/bin/mongod --quiet -f /etc/mongodb.conf run

Checking iwhd ...
 Success: iwhd.service - LSB: image warehouse daemon
	  Loaded: loaded (/etc/rc.d/init.d/iwhd)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:51 -0400; 15h ago
	Main PID: 5979 (iwhd)
	  CGroup: name=systemd:/system/iwhd.service
		  └ 5979 iwhd -c /etc/iwhd/conf.js -d localhost:27017 -l /v...

Checking postgresql ...
 Success: postgresql.service - LSB: start and stop PostgreSQL server
	  Loaded: loaded (/etc/rc.d/init.d/postgresql)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:05 -0400; 15h ago
	Main PID: 5697 (postmaster)
	  CGroup: name=systemd:/system/postgresql.service
		  ├ 5697 /usr/bin/postmaster -p 5432 -D /var/lib/pgsql/data...
		  ├ 5699 postgres: logger process   
		  ├ 5701 postgres: writer process   
		  ├ 5702 postgres: wal writer process   
		  ├ 5703 postgres: autovacuum launcher process   
		  ├ 5704 postgres: stats collector process   
		  └ 5787 postgres: aeolus conductor ::1(50780) idle

Checking httpd ...
 Success: httpd.service - LSB: start and stop Apache HTTP Server
	  Loaded: loaded (/etc/rc.d/init.d/httpd)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:56 -0400; 15h ago
	Main PID: 5379 (httpd)
	  CGroup: name=systemd:/system/httpd.service
		  ├ 5379 /usr/sbin/httpd
		  ├ 5433 /usr/sbin/httpd
		  ├ 5434 /usr/sbin/httpd
		  ├ 5435 /usr/sbin/httpd
		  ├ 5436 /usr/sbin/httpd
		  ├ 5437 /usr/sbin/httpd
		  ├ 5438 /usr/sbin/httpd
		  ├ 5439 /usr/sbin/httpd
		  ├ 5440 /usr/sbin/httpd
		  ├ 7332 /usr/sbin/httpd
		  ├ 7333 /usr/sbin/httpd
		  └ 7334 /usr/sbin/httpd

Checking qpidd ...
 Success: qpidd.service - LSB: start or stop qpidd
	  Loaded: loaded (/etc/rc.d/init.d/qpidd)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:58 -0400; 15h ago
	Main PID: 5467 (qpidd)
	  CGroup: name=systemd:/system/qpidd.service
		  └ 5467 /usr/sbin/qpidd --data-dir /var/lib/qpidd --daemon...

Checking deltacloud-core ...
 Success: deltacloud-core.service - LSB: Deltacloud Core API deamon
	  Loaded: loaded (/etc/rc.d/init.d/deltacloud-core)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:58 -0400; 15h ago
	Main PID: 5529 (deltacloudd)
	  CGroup: name=systemd:/system/deltacloud-core.service
		  └ 5529 /usr/bin/ruby /usr/bin/deltacloudd -i mock -e prod...

Checking libvirtd ...
 Success: libvirtd.service - LSB: daemon for libvirt virtualization API
	  Loaded: loaded (/etc/rc.d/init.d/libvirtd)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:55 -0400; 15h ago
	Main PID: 5248 (libvirtd)
	  CGroup: name=systemd:/system/libvirtd.service
		  ├ 5248 libvirtd --daemon
		  └ 5345 /usr/sbin/dnsmasq --strict-order --bind-interfaces...

Checking aeolus-conductor ...
 Success: aeolus-conductor.service - SYSV: aeolus-conductor is the primary server process for the
	  Loaded: loaded (/etc/rc.d/init.d/aeolus-conductor)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:29 -0400; 15h ago
	Main PID: 5768 (thin)
	  CGroup: name=systemd:/system/aeolus-conductor.service
		  └ 5768 thin server (127.0.0.1:3000)                      ...

Checking conductor-dbomatic ...
 Success: conductor-dbomatic.service - SYSV: conductor-dbomatic populates the Aeolus Conductor db from
	  Loaded: loaded (/etc/rc.d/init.d/conductor-dbomatic)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:51 -0400; 15h ago
	Main PID: 5929 (dbomatic)
	  CGroup: name=systemd:/system/conductor-dbomatic.service
		  └ 5929 /usr/bin/ruby /usr/share/aeolus-conductor/dbomatic...

Checking imagefactory ...
 Success: imagefactory.service - LSB: start and stop Image Factory qmf agent
	  Loaded: loaded (/etc/rc.d/init.d/imagefactory)
	  Active: active (running) since Wed, 21 Sep 2011 14:54:13 -0400; 19h ago
	Main PID: 4586 (imagefactory)
	  CGroup: name=systemd:/system/imagefactory.service
		  └ 4586 /usr/bin/python /usr/bin/imagefactory --qmf --debu...

Checking ntpd ...
 Success: ntpd.service - Network Time Service
	  Loaded: loaded (/lib/systemd/system/ntpd.service)
	  Active: active (running) since Wed, 21 Sep 2011 23:26:14 -0400; 10h ago
	Main PID: 8778 (ntpd)
	  CGroup: name=systemd:/system/ntpd.service
		  └ 8778 /usr/sbin/ntpd -n -u ntp:ntp -g


[root@unused aeolus-conductor]# rpm -qa |grep aeolus
aeolus-conductor-0.4.0-0.20110921152740gitac47a38.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110921152740gitac47a38.fc15.noarch
aeolus-all-0.4.0-0.20110921152740gitac47a38.fc15.noarch
aeolus-configure-2.0.2-4.20110921102958gitcaa9608.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110921152740gitac47a38.fc15.noarch
[root@unused aeolus-conductor]# ^C


Note You need to log in before you can comment on or make changes to this bug.