Bug 73952 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: libdbi (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 11:39 EDT by Enrico Scholz
Modified: 2013-07-02 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-31 15:24:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 11:39:00 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/include/dbi /usr/include/dbi/dbd.h
| file /usr/include/dbi is not owned by any package
| libdbi-devel-0.6.5-2


Version-Release number of selected component (if applicable):

libdbi-devel-0.6.5-2


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that libdbi-devel is uninstalled completely
   (rm -rf /usr/include/dbi)
3. rpm -U libdbi-devel-0.6.5-2.i386.rpm
4. ls -l /usr/include/dbi
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e libdbi-devel-0.6.5-2

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 16:45 /usr/include/dbi
* files can not be found/read at 5 and
* /usr/include/dbi still exists after 6.
Comment 1 Patrick Macdonald 2003-01-24 14:43:44 EST
Ton, please have a look.
Comment 2 Tom Lane 2003-01-24 19:32:46 EST
Specfile fixed in CVS, still need to push to build process.
Comment 3 Tom Lane 2003-01-31 15:24:15 EST
Fix verified in rawhide.

Note You need to log in before you can comment on or make changes to this bug.