Bug 739551 - Firstboot - inconsistent state when going "back" after registering
Summary: Firstboot - inconsistent state when going "back" after registering
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 715031
TreeView+ depends on / blocked
 
Reported: 2011-09-19 13:30 UTC by Michael Stead
Modified: 2013-01-10 10:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-16 14:37:21 UTC


Attachments (Terms of Use)

Description Michael Stead 2011-09-19 13:30:41 UTC
Description of problem:
Should not be able to go back to the registration screen once registered.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start firstboot
2. Register with candlepin
3. Now click Back

Actual results:
You're back on the registration form even though you are already registered. 
The user can enter a new user/pw here and try to register again, which appears
to succeed but is actually in a failed state.

Expected results:
- Back button is disabled on the subscription-manager screen.
- Registration dialog is not shown if already registered (identity cert exists) and subscription manager screen is show.
   

Additional info:
This is currently fixed for RHEL 6.2 but couldn't get access to the back button for 5.7

Comment 1 John Sefler 2011-09-23 14:32:03 UTC
referencing original bug 642660 from which this bug was derived

Comment 2 James Bowes 2011-12-16 14:37:21 UTC
Since I got the back button working properly for another bug, i'm going to mark this one as NOTABUG


Note You need to log in before you can comment on or make changes to this bug.