Bug 739663 - Dig doesn't work
Dig doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 14:30 EDT by Erinn Looney-Triggs
Modified: 2013-04-30 19:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: bind-9.8.3-2.P1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 05:22:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erinn Looney-Triggs 2011-09-19 14:30:05 EDT
Description of problem:
Looks like it is looking for the wrong version of the library.

dig
dig: error while loading shared libraries: libisccfg.so.80: cannot open shared object file: No such file or directory

rpm -ql bind-libs
/usr/lib64/libbind9.so.80
/usr/lib64/libbind9.so.80.0.3
/usr/lib64/libdns.so.81
/usr/lib64/libdns.so.81.3.1
/usr/lib64/libisc.so.83
/usr/lib64/libisc.so.83.0.1
/usr/lib64/libisccc.so.80
/usr/lib64/libisccc.so.80.0.0
/usr/lib64/libisccfg.so.82
/usr/lib64/libisccfg.so.82.0.0
/usr/lib64/liblwres.so.80
/usr/lib64/liblwres.so.80.0.1

Version-Release number of selected component (if applicable):
rpm -q bind bind-libs
bind-9.8.1-2.fc16.x86_64
bind-libs-9.8.1-2.fc16.x86_64


How reproducible:
Type dig


Additional info:
Comment 1 Adam Tkac 2011-09-21 07:41:54 EDT
Please update also bind-utils package, it should fix the issue.

I will add the versioned bind-libs Requires into bind-utils so this won't happen again.
Comment 2 Erinn Looney-Triggs 2011-09-21 12:33:58 EDT
Hmm bind-utils seems to believe it is up to date:
Package 32:bind-utils-9.8.1-2.fc16.x86_64 already installed and latest version
Nothing to do
Comment 3 Adam Tkac 2011-09-21 13:07:55 EDT
And dig still doesn't work? What says `rpm -qV bind-utils`?
Comment 4 Erinn Looney-Triggs 2011-09-21 13:10:54 EDT
rpm -qV bind-utils
missing     /etc/trusted-key.key
prelink: /usr/bin/dig: Could not find one of the dependencies
prelink: /usr/bin/dig: at least one of file's dependencies has changed since prelinking
?S.T.....    /usr/bin/dig
prelink: /usr/bin/host: Could not find one of the dependencies
prelink: /usr/bin/host: at least one of file's dependencies has changed since prelinking
?S.T.....    /usr/bin/host
prelink: /usr/bin/nslookup: Could not find one of the dependencies
prelink: /usr/bin/nslookup: at least one of file's dependencies has changed since prelinking
?S.T.....    /usr/bin/nslookup
prelink: /usr/bin/nsupdate: Could not find one of the dependencies
prelink: /usr/bin/nsupdate: at least one of file's dependencies has changed since prelinking
?S.T.....    /usr/bin/nsupdate
...T.....  d /usr/share/man/man1/dig.1.gz
...T.....  d /usr/share/man/man1/host.1.gz
...T.....  d /usr/share/man/man1/nslookup.1.gz
...T.....  d /usr/share/man/man1/nsupdate.1.gz
Comment 5 Erinn Looney-Triggs 2011-09-21 13:13:24 EDT
Sorry missed the first question, no dig still does not work, same error.

-Erinn
Comment 6 Göran Uddeborg 2011-09-26 06:19:51 EDT
May I ask why the libisccfg.so.82 dependency wasn't there from the start?  I mean, these kinds of dependencies are typically deducted automatically.  Have you done something to filter it out?  Or is there a bug in the dependency analyzer of rpm that merits a bug report of its own?
Comment 7 Adam Tkac 2011-09-26 09:59:25 EDT
(In reply to comment #5)
> Sorry missed the first question, no dig still does not work, same error.
> 
> -Erinn

It seems that your installation of the bind-utils package is broken. Can you please run `yum reinstall bind-libs bind-utils`? This should fix it.
Comment 8 Adam Tkac 2011-09-26 10:01:30 EDT
(In reply to comment #6)
> May I ask why the libisccfg.so.82 dependency wasn't there from the start?  I
> mean, these kinds of dependencies are typically deducted automatically.  Have
> you done something to filter it out?  Or is there a bug in the dependency
> analyzer of rpm that merits a bug report of its own?

There is a filter in the bind.spec which does some "magic" with dependencies and bind-utils really doesn't have libisccfg.so.82 in the requires. I will remove this filter in next update because it is outdated and unneeded now. Thanks for the spot!
Comment 9 Erinn Looney-Triggs 2011-09-26 11:36:24 EDT
Re-install now works for me, I will leave it up to you if you want to close this given some of the changes you have done in this bug report.
Comment 10 Adam Tkac 2012-07-19 05:22:22 EDT
Closing this issue because bind-9.8.3-2.P1.fc16, which doesn't have the broken dependency filter, is already in Fedora 16 updates.

Note You need to log in before you can comment on or make changes to this bug.