Bug 73968 - Does not work when installed with an umask of 077 and messes filesystem
Summary: Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python-optik (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact:
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 15:45 UTC by Enrico Scholz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 13:08:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 15:45:09 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/python2.2/site-packages/optik /usr/lib/python2.2/site-packages/optik/__init__.py
| file /usr/lib/python2.2/site-packages/optik is not owned by any package
| python-optik-1.3-2


Version-Release number of selected component (if applicable):

python-optik-1.3-2


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that python-optik is uninstalled completely
   (rm -rf /usr/lib/python2.2/site-packages/optik)
3. rpm -U python-optik-1.3-2.noarch.rpm
4. ls -l /usr/lib/python2.2/site-packages/optik
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e python-optik-1.3-2

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 17:04 /usr/lib/python2.2/site-packages/optik
* files can not be found/read at 5 and
* /usr/lib/python2.2/site-packages/optik still exists after 6.

Comment 1 Mihai Ibanescu 2002-09-13 15:50:36 UTC
Right. Distutils problem, I'll try to patch it and ship the patch upstream.

Comment 2 Mihai Ibanescu 2002-12-03 17:02:57 UTC
Added the directory. Not really nice, oh well. Should be in Rawhide.

Comment 3 Enrico Scholz 2003-02-25 13:08:27 UTC
Fix verified. Thanks.


Note You need to log in before you can comment on or make changes to this bug.