Bug 739702 - Pressing "submit" quickly causes more than one job to be submitted
Summary: Pressing "submit" quickly causes more than one job to be submitted
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin
Version: 2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: grid-maint-list
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 19:54 UTC by Trevor McKay
Modified: 2016-05-26 20:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-26 20:17:28 UTC


Attachments (Terms of Use)

Description Trevor McKay 2011-09-19 19:54:41 UTC
Description of problem:

Pressing the submit button multiple times from the job submit form will cause more than 1 job to be submitted (can easily reproduce 2 jobs, more might be possible depending on what is happening in the program).

Version-Release number of selected component (if applicable):

This probably exists in 2.0, the code around submit has not changed lately.

How reproducible:

100%

Steps to Reproduce:
1.  Fill out a job form
2.  Click on the submit button as fast as you can (maybe even slower...  I had the same thing happen when there was a delay in processing the form)

  
Actual results:

More than 1 job submitted

Expected results:

Submit (or cancel) should be ignored after the first button press on the form

Comment 1 Trevor McKay 2011-09-21 14:25:51 UTC
Implementation note,

  looks like we need some Javascript changes to count button presses on the form and ignore presses after an initial "Submit" or "Cancel".  

  Make sure that if a "Submit" results in an error that another Submit/Cancel is possible (form with errors may be a new form, so it may not be a problem)

Comment 2 Trevor McKay 2011-09-26 18:41:50 UTC
Making this low priority after feedback from Justin and Ernie.  This falls into the bucket of "the web is broken" and is a general problem across many, many UIs that users should be familiar with.

Adding the JS stuff to count button presses probably will work but it is not something that needs to happen right away.

Comment 4 Anne-Louise Tangring 2016-05-26 20:17:28 UTC
MRG-Grid is in maintenance and only customer escalations will be considered. This issue can be reopened if a customer escalation associated with it occurs.


Note You need to log in before you can comment on or make changes to this bug.