Bug 739764 - anaconda fails to install at the last stage (grub) if there are any unused software raid arrays
anaconda fails to install at the last stage (grub) if there are any unused so...
Status: CLOSED DUPLICATE of bug 731973
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 20:23 EDT by N K
Modified: 2011-09-20 10:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-20 10:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description N K 2011-09-19 20:23:00 EDT
Description of problem:
Installation uses a custom partition layout.  The anaconda installer detects all pre-existing software raid arrays and LVMs, but only dynamically assembles the raid arrays the user chooses to install on.

Version-Release number of selected component (if applicable):
RHEL 6.1 anaconda installer

How reproducible:
very

Steps to Reproduce:
1. create a software raid array and an LVM over it
2. don't use it (i.e. don't assign any path like / or /opt or anything to it)
3. install, wait for last stage (installing grub)
  
Actual results:
RuntimeError: get_sysfs_path_by_name: Could not find sysfs path for '/dev/md2' (it is not at '/sys/class/block/md2')

Expected results:
Successful install

Additional info:
RuntimeError: get_sysfs_path_by_name: Could not find sysfs path for '/dev/md2' (it is not at '/sys/class/block/md2')
</binding><binding fileName="/tmp/anaconda-tb-UqOnrG" name="pythonUnhandledException" type="text">anaconda 13.21.117 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 805, in get_sysfs_path_by_name
    "for '%s' (it is not at '%s')" % (dev_node, dev_path))
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 416, in majorminor
    sysfs_path = get_sysfs_path_by_name(device)
  File "/usr/lib/anaconda/storage/formats/lvmpv.py", line 153, in writeKS
    f.write("pv.%s" % self.majorminor)
  File "/usr/lib/anaconda/storage/devices.py", line 2751, in writeKS
    self.format.writeKS(f)
  File "/usr/lib/anaconda/storage/__init__.py", line 1188, in writeKS
    device.writeKS(f, preexisting=preexisting, noformat=noformat)
  File "/usr/lib/anaconda/instdata.py", line 289, in writeKS
    self.storage.writeKS(f)
  File "/usr/lib/anaconda/packages.py", line 66, in writeKSConfiguration
    anaconda.id.writeKS(fn)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1389, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1410, in handleRenderCallback
    self.currentWindow.renderCallback()
Comment 2 David Cantrell 2011-09-20 10:34:49 EDT

*** This bug has been marked as a duplicate of bug 731973 ***

Note You need to log in before you can comment on or make changes to this bug.