Bug 73979 - Does not work when installed with an umask of 077 and messes filesystem
Summary: Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 16:33 UTC by Enrico Scholz
Modified: 2015-01-08 00:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 15:04:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 16:33:30 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/share/rhn /usr/share/rhn/BETA-RPM-GPG-KEY
| file /usr/share/rhn is not owned by any package
| up2date-2.9.46-1


Version-Release number of selected component (if applicable):

up2date-2.9.46-1


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that up2date is uninstalled completely
   (rm -rf /usr/share/rhn)
3. rpm -U up2date-2.9.46-1.i386.rpm
4. ls -l /usr/share/rhn
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e up2date-2.9.46-1

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 17:59 /usr/share/rhn
* files can not be found/read at 5 and
* /usr/share/rhn still exists after 6.

Comment 1 Adrian Likins 2003-01-21 04:19:32 UTC
added /usr/share/rhn and /usr/share/rhn/up2date_client to
the list of dirs owned by the package. Should
show up in 3.1.3 or higher

Comment 2 Jay Turner 2003-02-14 15:04:03 UTC
Fix confirmed with up2date-3.1.15-7.


Note You need to log in before you can comment on or make changes to this bug.