Bug 73984 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On: 73892 77048
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 12:37 EDT by Enrico Scholz
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 08:43:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 12:37:07 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/libexec/emacs /usr/libexec/emacs/21.2/i686-pc-linux-gnu/cvtmail
| file /usr/libexec/emacs is not owned by any package
| emacs-21.2-16


Version-Release number of selected component (if applicable):

emacs-21.2-16


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that emacs is uninstalled completely
   (rm -rf /usr/libexec/emacs)
3. rpm -U emacs-21.2-16.i386.rpm
4. ls -l /usr/libexec/emacs
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e emacs-21.2-16

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 18:23 /usr/libexec/emacs
* files can not be found/read at 5 and
* /usr/libexec/emacs still exists after 6.
Comment 1 Jens Petersen 2002-10-30 18:08:36 EST
Thank you very much for finding all these unowned directories. :-)

This one should be fixed in the next emacs package release.
Comment 2 Enrico Scholz 2002-10-30 19:18:30 EST
Because I forgot to mention the URL explicitly in the first bunch of
unowned-directory-reports and because you spoke about _one_ directory only, I am
not sure if you have seen and fixed the other ones also. So please visit the URL
if necessary; it is listing all the problematic directories 

My apologies about the incomplete report.
Comment 3 Jens Petersen 2002-10-30 23:48:25 EST
Right, but if I understood correctly the other directories are all
subdirs of "/usr/libexec/emacs/".
Comment 4 Enrico Scholz 2002-10-31 06:52:13 EST
Yes,

* /usr/libexec/emacs
* /usr/libexec/emacs/21.2
* /usr/libexec/emacs/21.2/i686-pc-linux-gnu

are the questionable directories. /usr/libexec and /usr/share/applications are
unowned-directories of the emacs-package also, but are special and more common
cases. For /usr/libexec see bug #73892.


I have not seen the new package yet and do not know, what you meant with "This
one should be fixed". When just writing:

| %files
| ...
| %dir /usr/libexec/emacs

the 21.2 and 21.2/i686-pc-linux-gnu directories would be unowned still. But when
writing

| /usr/lib/libexec/*

this report can be closed. But you should keep the /usr/share/applications
directory in your mind and add a requirement when its ownership is assigned.
Comment 5 Jens Petersen 2002-11-04 21:12:49 EST
The package isn't down yet, but should be out before too long.

I have:

| /usr/lib/libexec/emacs

in the %files list now.  (I'll change the status to Modified when
the package is ready.  Thanks for your patience. :)

Do you have a bug number for "/usr/share/applications"?
Comment 6 Enrico Scholz 2002-11-04 23:40:26 EST
The /usr/share/applications issue was entered as bug #77048.
Comment 7 Jens Petersen 2002-11-06 03:26:24 EST
The ownership of "/usr/lib/libexec/emacs" should be fixed in 21.2-20.

I personally agreed that "libexec/" and "applications/" should be owned
by some central package in RHL.
Comment 8 Enrico Scholz 2003-02-25 08:43:49 EST
Fix verified. Thanks.

Note You need to log in before you can comment on or make changes to this bug.