Bug 739849 - Register RHN will fail after register satellite.
Summary: Register RHN will fail after register satellite.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 6.2
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 901490
TreeView+ depends on / blocked
 
Reported: 2011-09-20 08:26 UTC by cshao
Modified: 2016-04-26 15:42 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.8.gite7ea5d6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 901490 (view as bug list)
Environment:
Last Closed: 2011-12-06 19:28:10 UTC


Attachments (Terms of Use)
ovirt.log (31.52 KB, text/plain)
2011-09-20 08:26 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description cshao 2011-09-20 08:26:19 UTC
Created attachment 523977 [details]
ovirt.log

Description of problem:
Register satellite can successful(the URL and CA info will be saved), but register RHN will fail after register satellite.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.17.2.el6

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H, register satellite first.
2. After register satellite, continue register RHEV-H to RHN.(The URL and CA info are existing as default.)
3. Please correct entered information(user name and password).
  
Actual results:
Register RHN will fail after register satellite.
If delete the satellite's URL and CA info, register to RHN can successful.

ovirt.log
=====================================
Error registering to RHN account!
current page: 15
RHN Config does not exist
/etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT
File already persisted: /etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT

/etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT Already persisted

Registering to RHN account.....
['/usr/sbin/rhnreg_ks', '--serverUrl', 'https://10.66.73.127/XMLRPC', '--sslCACert', '/etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT', '--username', 'qa@redhat.com', '--password', 'XXXXXXXX', '--novirtinfo', '--norhnsd', '--nopackages', '--force']

Error Message:
    Attempt to register a system to an invalid username
Error Class Code: 2
Error Class Info: Invalid username and password combination.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Expected results:
Register RHN or satellite can successful.

Additional info:

Comment 7 errata-xmlrpc 2011-12-06 19:28:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.