Bug 73985 - rep-gtk should own more directories
rep-gtk should own more directories
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rep-gtk (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
http://www.tu-chemnitz.de/~ensc/dirch...
: EasyFix, Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-09-13 12:45 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 14:52:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 12:45:15 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/libexec/rep/i386-redhat-linux-gnu/gui /usr/libexec/rep/i386-redhat-linux-gnu/gui/gtk-2
| file /usr/libexec/rep/i386-redhat-linux-gnu/gui is not owned by any package
| rep-gtk-0.16.0.90-4


Version-Release number of selected component (if applicable):

rep-gtk-0.16.0.90-4


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that rep-gtk is uninstalled completely
   (rm -rf /usr/libexec/rep/i386-redhat-linux-gnu/gui)
3. rpm -U rep-gtk-0.16.0.90-4.i386.rpm
4. ls -l /usr/libexec/rep/i386-redhat-linux-gnu/gui
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e rep-gtk-0.16.0.90-4

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 18:35 /usr/libexec/rep/i386-redhat-linux-gnu/gui
* files can not be found/read at 5 and
* /usr/libexec/rep/i386-redhat-linux-gnu/gui still exists after 6.
Comment 1 Elliot Lee 2003-02-25 14:52:18 EST
0.17-5 will fix this eventually

Note You need to log in before you can comment on or make changes to this bug.