Bug 739865 - Installation with driverdisk missing dependencies
Summary: Installation with driverdisk missing dependencies
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: i386
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-09-20 09:09 UTC by Ľuboš Kardoš
Modified: 2016-08-01 01:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 10:59:49 UTC


Attachments (Terms of Use)
Warnig showed after package selection (98.61 KB, image/png)
2011-09-20 09:09 UTC, Ľuboš Kardoš
no flags Details
File: anaconda.log (22.94 KB, text/plain)
2011-09-21 08:44 UTC, Ľuboš Kardoš
no flags Details
File: yum.log (61.11 KB, text/plain)
2011-09-21 08:44 UTC, Ľuboš Kardoš
no flags Details

Description Ľuboš Kardoš 2011-09-20 09:09:43 UTC
Created attachment 523990 [details]
Warnig showed after package selection

Description of problem:
During installation with driverdisk after package selection warning is showed:
"Some of packages you have selected for install are missing dependencies..."

Version-Release number of selected component (if applicable):
RHEL6.2-20110907.1 i386 / Server 

How reproducible:

Prepare driverdisk iso image for current build with modified drivers. (see https://wiki.test.redhat.com/pholica/DriverdiskInstructions)

Create partiton (or prepare flash drive) with "OEMDRV" file system label on machine the test will be run on.

Put content of driverdisk iso on this partition.
  
Actual results:
After package selection warning is showed:
"Some of packages you have selected for install are missing dependencies..."

Additional info:
I have tested this installation on RHEL6.1 i386 / Server too and installation was successful, no warning was showed.

Comment 2 Chris Lumens 2011-09-20 14:03:26 UTC
To me, this looks like a problem with how the driver disk was constructed.  anaconda is just warning here that what your DD package requires is not available, for whatever reason.  However, I do not know much about driver disks so I can't say for sure what the problem there is.

Comment 3 Martin Sivák 2011-09-20 14:26:24 UTC
Hi Luboš: Can you please attach the anaconda.log and yum.log from the install environment? We can then identity the package which caused this. Anaconda uses DD just as every other repository and you are probably missing dependencies there.

Comment 4 Ľuboš Kardoš 2011-09-21 08:44:10 UTC
Created attachment 524155 [details]
File: anaconda.log

Comment 5 Ľuboš Kardoš 2011-09-21 08:44:48 UTC
Created attachment 524157 [details]
File: yum.log

Comment 6 Martin Sivák 2011-09-21 10:59:49 UTC
Ok so it is simple. The module (virtio_blk) you used on the driver disc is not compatible with the running kernel.


Note You need to log in before you can comment on or make changes to this bug.