Bug 73989 - [kWnn] Does not work when installed with an umask of 077 and messes filesystem
[kWnn] Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: FreeWnn (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 13:06 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 07:49:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 13:06:46 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /var/lib/wnn /var/lib/wnn/ko_KR
| file /var/lib/wnn is not owned by any package
| kWnn-1.11-26

IMO this directory should be owned by the FreeWnn-common package which
is required by kWnn.


Version-Release number of selected component (if applicable):

kWnn-1.11-26


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that kWnn is uninstalled completely
   (rm -rf /var/lib/wnn)
3. rpm -U kWnn-1.11-26.i386.rpm
4. ls -l /var/lib/wnn
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e kWnn-1.11-26

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 18:28 /var/lib/wnn
* files can not be found/read at 5 and
* /var/lib/wnn still exists after 6.
Comment 1 Jens Petersen 2003-04-21 07:49:58 EDT
These days the kWnn subpackage is nolonger being built by FreeWnn.

/var/lib/wnn is owned by FreeWnn at least, which seems good enough
for jserver.

Note You need to log in before you can comment on or make changes to this bug.