Bug 739948 - [RHEL6.2] PANIC while running /kernel/storage/iscsi/iscsi-target-ipv4 test
Summary: [RHEL6.2] PANIC while running /kernel/storage/iscsi/iscsi-target-ipv4 test
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 1359574 1366045
TreeView+ depends on / blocked
 
Reported: 2011-09-20 14:17 UTC by PaulB
Modified: 2016-09-05 20:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-08 01:52:53 UTC


Attachments (Terms of Use)

Description PaulB 2011-09-20 14:17:00 UTC
Description of problem:
 While running /kernel/storage/iscsi/iscsi-target-ipv4 test, we had a kernel panic on Dell Power Edge 2950 systems.

Version-Release number of selected component (if applicable):
 2.6.32-194.el6 i386

How reproducible:
 The PANIC is intermittent, but was reproduced.

Steps to Reproduce:
1. Clone the following Beaker job:
   https://beaker.engineering.redhat.com/jobs/128353
2. Install system with RHEL6-6.1_nfs-Server.
3. Installing kernel 2.6.32-194.el6.
4. testing  /kernel/storage/iscsi/iscsi-target-ipv4
5. use one of the two Dell Power Edge 2950 systems
   listed in the following comment as the client (initiator).
  
Actual results:
https://beaker.engineering.redhat.com/jobs/128353
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2011/09/1283/128353/265985//console.log
<-SNIP->
---[ end trace 02c173272e271212 ]--- 
Kernel panic - not syncing: Fatal exception in interrupt 
Pid: 0, comm: swapper Tainted: G      D    ----------------   2.6.32-194.el6.i686 #1 
Call Trace: 
 [<c082d4b4>] ? panic+0x42/0xf9 
 [<c08313d8>] ? oops_end+0xc8/0xd0 
 [<c0432fc2>] ? no_context+0xc2/0x190 
 [<c04331ef>] ? bad_area_nosemaphore+0xf/0x20 
 [<c0433668>] ? __do_page_fault+0x2d8/0x420 
 [<c0832d2a>] ? do_page_fault+0x2a/0x90 
 [<c0832d00>] ? do_page_fault+0x0/0x90 
 [<c08307b7>] ? error_code+0x73/0x78 
 [<c05e3db7>] ? __blk_complete_request+0x17/0x100 
 [<f7e920c4>] ? __iscsi_put_task+0x94/0x100 [libiscsi] 
 [<f7e91bd9>] ? iscsi_itt_to_ctask+0x39/0x90 [libiscsi] 
 [<f7e95f09>] ? __iscsi_complete_pdu+0x1f9/0x8f0 [libiscsi] 
 [<f91d6d26>] ? bnx2_start_xmit+0x1b6/0x6e0 [bnx2] 
 [<f7e96634>] ? iscsi_complete_pdu+0x34/0x6d [libiscsi] 
 [<f7e5433e>] ? iscsi_tcp_hdr_recv_done+0x1fe/0xa98 [libiscsi_tcp] 
 [<f7e537cc>] ? iscsi_tcp_segment_done+0x5c/0x2e0 [libiscsi_tcp] 
 [<c07ab8e6>] ? nf_iterate+0x66/0x80 
 [<c078bf00>] ? dev_queue_xmit+0x50/0x6b0 
 [<f7e53ad7>] ? iscsi_tcp_recv_skb+0x87/0x3f0 [libiscsi_tcp] 
 [<c07b94e5>] ? ip_finish_output+0x105/0x280 
 [<c07b96ea>] ? ip_output+0x8a/0xb0 
 [<f7ed1f20>] ? iscsi_sw_tcp_recv+0x40/0xf0 [iscsi_tcp] 
 [<c07c231e>] ? tcp_read_sock+0xee/0x210 
 [<f7ed1ee0>] ? iscsi_sw_tcp_recv+0x0/0xf0 [iscsi_tcp] 
 [<f7ed2299>] ? iscsi_sw_tcp_data_ready+0x49/0xd4 [iscsi_tcp] 
 [<c07c9ef7>] ? tcp_rcv_established+0x247/0x760 
 [<c07d151f>] ? tcp_v4_do_rcv+0x27f/0x3c0 
 [<c07b29d2>] ? ip_route_input+0x62/0x540 
 [<c07d2ac3>] ? tcp_v4_rcv+0x473/0x770 
 [<c07b460f>] ? ip_local_deliver_finish+0x9f/0x260 
 [<c07b3ea3>] ? ip_rcv_finish+0xf3/0x390 
 [<c0787c19>] ? __netif_receive_skb+0x409/0x5f0 
 [<c07e0e04>] ? inet_gro_receive+0x194/0x220 
 [<c078976f>] ? netif_receive_skb+0x3f/0x50 
 [<c078983f>] ? napi_skb_finish+0x2f/0x40 
 [<c078bc15>] ? napi_gro_receive+0x25/0x40 
 [<f91d989d>] ? bnx2_poll_work+0xc2d/0x10b0 [bnx2] 
 [<c040f240>] ? nommu_sync_single_for_device+0x0/0x10 
 [<c0483bfc>] ? clockevents_program_event+0x8c/0x120 
 [<c0427ad3>] ? lapic_next_event+0x13/0x20 
 [<c0483bfc>] ? clockevents_program_event+0x8c/0x120 
 [<f91d9e17>] ? bnx2_poll+0x47/0x240 [bnx2] 
 [<c047abc1>] ? __hrtimer_start_range_ns+0x151/0x3c0 
 [<c078bd0e>] ? net_rx_action+0xde/0x280 
 [<c045bcda>] ? __do_softirq+0x8a/0x1a0 
 [<c04b71e1>] ? move_native_irq+0x11/0x50 
 [<c045be2d>] ? do_softirq+0x3d/0x50 
 [<c045bf85>] ? irq_exit+0x65/0x70 
 [<c040b110>] ? do_IRQ+0x50/0xc0 
 [<c0428373>] ? smp_apic_timer_interrupt+0x53/0x90 
 [<c0409ff0>] ? common_interrupt+0x30/0x38 
 [<c0411251>] ? mwait_idle+0x61/0xc0 
 [<c0408964>] ? cpu_idle+0x94/0xd0 
 [<c0a929f7>] ? start_kernel+0x3b0/0x3b5 
 [<c0a92485>] ? unknown_bootoption+0x0/0x190 
panic occurred, switching back to text console 
BUG: scheduling while atomic: swapper/0/0x10000100 
Modules linked in: ext2 be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi sunrpc p4_clockmod ipv6 dm_mirror dm_region_hash dm_log bnx2 microcode dcdbas serio_raw iTCO_wdt iTCO_vendor_support i5000_edac edac_core i5k_amb sg ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom megaraid_sas pata_acpi ata_generic ata_piix usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core dm_mod [last unloaded: mperf] 
Modules linked in: ext2 be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi sunrpc p4_clockmod ipv6 dm_mirror dm_region_hash dm_log bnx2 microcode dcdbas serio_raw iTCO_wdt iTCO_vendor_support i5000_edac edac_core i5k_amb sg ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom megaraid_sas pata_acpi ata_generic ata_piix usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core dm_mod [last unloaded: mperf] 
 
Pid: 0, comm: swapper Tainted: G      D    ----------------   2.6.32-194.el6.i686 #1 Dell Inc. PowerEdge 2950/0NH278 
EIP: 0060:[<c0411251>] EFLAGS: 00000246 CPU: 0 
EIP is at mwait_idle+0x61/0xc0 
EAX: 00000000 EBX: 00000000 ECX: 00000000 EDX: 00000000 
ESI: 00000000 EDI: c0a2b000 EBP: 00f64003 ESP: c0a07fac 
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068 
Process swapper (pid: 0, ti=c0a06000 task=c0a2e560 task.ti=c0a06000) 
Stack: 
 c0a8efb4 00000000 c0a2b000 c0408964 cc7785d2 00000067 72121b05 10d0ba72 
<0> c0acf760 00099800 c0a929f7 000000c3 c0a92485 c094ba36 b23408c0 00000065 
<0> 5b16e2e2 00de33ac c0acf760 00040800 00000000 
Call Trace: 
 [<c0408964>] ? cpu_idle+0x94/0xd0 
 [<c0a929f7>] ? start_kernel+0x3b0/0x3b5 
 [<c0a92485>] ? unknown_bootoption+0x0/0x190 
Code: b0 c0 f6 44 11 27 02 75 31 31 d2 83 c0 08 89 d1 0f 01 c8 0f ae f0 89 f6 89 e0 25 00 e0 ff ff f6 40 08 08 75 22 31 c0 fb 0f 01 c9 <8b> 1c 24 8b 74 24 04 8b 7c 24 08 83 c4 0c c3 0f ae 78 08 89 e0  
Call Trace: 
 [<c0408964>] ? cpu_idle+0x94/0xd0 
 [<c0a929f7>] ? start_kernel+0x3b0/0x3b5 
 [<c0a92485>] ? unknown_bootoption+0x0/0x190 
<-SNIP->

Expected results:
 This test should pass successfully.

Additional info:
 See following comment for system hostnames and further test data.

Comment 5 RHEL Product and Program Management 2011-10-07 15:49:04 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.


Note You need to log in before you can comment on or make changes to this bug.