Bug 739973 - Open Box Configuration: Failed to load an rc.xml
Summary: Open Box Configuration: Failed to load an rc.xml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: obconf
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 15:20 UTC by Aleksandra Fedorova
Modified: 2011-10-09 19:32 UTC (History)
2 users (show)

Fixed In Version: lxappearance-obconf-0.1.2-0.1.20110828git02aeaab2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-09 19:32:43 UTC


Attachments (Terms of Use)

Description Aleksandra Fedorova 2011-09-20 15:20:59 UTC
Description of problem:

  When in LXDE-session obconf looks for its configuration file in a wrong place.

  strace shows:

  stat64("/home/bookwar/.config/openbox/home/bookwar/.config/openbox/lxde-rc.xml", 0xbfde7930) = -1 ENOENT (No such file or directory)
  stat64("/etc/xdg/openbox/home/bookwar/.config/openbox/lxde-rc.xml", 0xbfde7930) = -1 ENOENT (No such file or directory)

  It seems to be known bug, which is previously reported and fixed upstream
  https://bugs.archlinux.org/task/25619
  https://bugzilla.icculus.org/show_bug.cgi?id=5046

Version-Release number of selected component (if applicable):
  Fedora RC1 with @lxde group installed

  openbox-libs-3.5.0-1.fc16.i686
  obconf-2.0.3-7.20100212gitb04658.fc16.i686
  openbox-3.5.0-1.fc16.i686
  lxappearance-obconf-0.1.2-0.1.20110828git02aeaab2.fc16.i686


How reproducible:
  always

Steps to Reproduce:
  Run obconf from menu or command line.

Comment 1 Fedora Update System 2011-09-30 12:51:06 UTC
obconf-2.0.3-8.20100212gitb04658.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/obconf-2.0.3-8.20100212gitb04658.fc16

Comment 2 Fedora Update System 2011-09-30 19:24:44 UTC
Package obconf-2.0.3-8.20100212gitb04658.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing obconf-2.0.3-8.20100212gitb04658.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/obconf-2.0.3-8.20100212gitb04658.fc16
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2011-10-04 12:36:36 UTC
lxappearance-obconf-0.1.2-0.1.20110828git02aeaab2.fc16, openbox-3.5.0-2.fc16, obconf-2.0.3-8.20100212gitb04658.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-12338

Comment 4 Fedora Update System 2011-10-09 19:32:43 UTC
lxappearance-obconf-0.1.2-0.1.20110828git02aeaab2.fc16, openbox-3.5.0-2.fc16, obconf-2.0.3-8.20100212gitb04658.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.