Bug 739995 - NULL variable dereferencing
Summary: NULL variable dereferencing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Fabio Massimo Di Nitto
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 16:07 UTC by Michal Luscon
Modified: 2011-09-21 10:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 07:50:43 UTC


Attachments (Terms of Use)

Description Michal Luscon 2011-09-20 16:07:29 UTC
Description of problem:

/cman/lib/libcman.c:1010 - Dereferencing variable "name" before a null check(line #1013).

Version-Release number of selected component (if applicable):
cluster-3.0.12.1-19.el6

Additional info:
This defect was not present in the previous version of cluster package.

Comment 2 Fabio Massimo Di Nitto 2011-09-20 17:42:08 UTC
Moving to 6.3

That same exact code existed in libcman for approx 6 years. The issue is that it did move pristine from one function to another function internally to libcman.

One warning has for sure disappeared from cman_register_quorum_device and the new one is showing in the common function called cman_set_quorum_device.


Note You need to log in before you can comment on or make changes to this bug.