Bug 74000 - [krbafs-devel] Does not work when installed with an umask of 077 and messes filesystem
Summary: [krbafs-devel] Does not work when installed with an umask of 077 and messes f...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krbafs (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 17:21 UTC by Enrico Scholz
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 21:39:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 17:21:10 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/kerberos/include /usr/kerberos/include/krbafs.h
| file /usr/kerberos/include is not owned by any package
| krbafs-devel-1.1.1-6


Because /usr/kerberos/include is owned by krb5-devel and krb5-devel is needed by
krbafs-devel, it should be added an explicit

| Requires: krb5-devel

to the spec-file.


Version-Release number of selected component (if applicable):

krbafs-devel-1.1.1-6


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that krbafs-devel is uninstalled completely
   (rm -rf /usr/kerberos/include)
3. rpm -U krbafs-devel-1.1.1-6.i386.rpm
4. ls -l /usr/kerberos/include
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e krbafs-devel-1.1.1-6

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 18:27 /usr/kerberos/include
* files can not be found/read at 5 and
* /usr/kerberos/include still exists after 6.

Comment 1 Miloslav Trmač 2004-10-12 21:39:33 UTC
krbafs.h is in /usr/include now.


Note You need to log in before you can comment on or make changes to this bug.