Bug 740016 - PackageKit-zif: refresh_cache, even with "force" set, only refreshes expired metadata
Summary: PackageKit-zif: refresh_cache, even with "force" set, only refreshes expired ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 15
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 17:37 UTC by Kevin Kofler
Modified: 2011-09-20 19:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-20 18:13:24 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2011-09-20 17:37:38 UTC
Description of problem:
I've hit this one while trying to update to a new zif build I pushed into my own repo. I KNOW there's a new build waiting in the repo, but KPackageKit won't show it to me, even after I explicitly ask it to refresh the available updates.

Version-Release number of selected component (if applicable):
PackageKit-zif-0.6.17-1.fc15.libzif.so.3.x86_64

How reproducible:
Always (when the metadata has changed without having expired).

Steps to Reproduce:
1. Try to refresh the list of available updates in KPackageKit.
  
Actual results:
Nothing changes.

Expected results:
The new updates get detected.

Additional info:
I noticed the code does nothing at all when "force" is not set (is that correct? I'd expect it to refresh the expired metadata in that case), and does nothing to ignore the expiration date when "force" is set (whereas PackageKit-yum does a repo.metadata_expire = 0 in refresh_cache; BTW, it does that always, unconditionally, even without "force", so it's no wonder we're seeing excessive refreshes with PackageKit-yum).

Comment 1 Kevin Kofler 2011-09-20 17:43:46 UTC
I filed bug #740018 against PackageKit-yum, because the code there really doesn't look right to me.

Comment 2 Kevin Kofler 2011-09-20 18:13:24 UTC
Uhm, actually that's probably not what's happening, I'm hitting some error inside zif itself, it's failing to load the metadata for my repo, I have to check what's going on.

Comment 3 Kevin Kofler 2011-09-20 18:22:08 UTC
Yes, it was my repodata which was corrupt (outdated repomd.xml left on the server), so my "I KNOW there's a new build waiting in the repo" assertion was where the PEBKAC was. Sorry for the bogus bug report.

Comment 4 Richard Hughes 2011-09-20 19:19:02 UTC
(In reply to comment #3)
> Yes, it was my repodata which was corrupt (outdated repomd.xml left on the
> server), so my "I KNOW there's a new build waiting in the repo" assertion was
> where the PEBKAC was. Sorry for the bogus bug report.

Dude, don't worry. I appreciate all the other bugs.


Note You need to log in before you can comment on or make changes to this bug.