Bug 74002 - Does not work when installed with an umask of 077 and messes filesystem
Summary: Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Jay Turner
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 17:27 UTC by Enrico Scholz
Modified: 2015-01-08 00:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 12:48:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 17:27:08 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/include/ncurses /usr/include/ncurses/cursesapp.h
| file /usr/include/ncurses is not owned by any package
| ncurses-c++-devel-5.2-28


Because /usr/include/ncurses is owned by ncurses-devel and ncurses-devel is needed
by ncurses-c++-devel, it should be added an explicit

| Requires: ncurses-devel

to the spec-file.


Version-Release number of selected component (if applicable):

ncurses-c++-devel-5.2-28


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that ncurses-c++-devel is uninstalled completely
   (rm -rf /usr/include/ncurses)
3. rpm -U ncurses-c++-devel-5.2-28.i386.rpm
4. ls -l /usr/include/ncurses
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e ncurses-c++-devel-5.2-28

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 18:40 /usr/include/ncurses
* files can not be found/read at 5 and
* /usr/include/ncurses still exists after 6.

Comment 1 Eido Inoue 2003-01-22 17:34:11 UTC
fixed in ncurses-5.3-1

Comment 2 Enrico Scholz 2003-02-25 12:48:34 UTC
Fix verified. Thanks.


Note You need to log in before you can comment on or make changes to this bug.