Bug 740038 - sysconfig times out with existing key
Summary: sysconfig times out with existing key
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Russell Bryant
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-20 18:55 UTC by Dave Johnson
Modified: 2011-12-06 11:43 UTC (History)
2 users (show)

Fixed In Version: matahari-0.4.4-5.el6
Doc Type: Bug Fix
Doc Text:
No description required.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:43:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-09-20 18:55:53 UTC
Description of problem:
=================================
Calling run_uri/string with a key containing special characters (dave's $$$) causes the call to time out.  This was working in v0.4.4-2. 


Version-Release number of selected component (if applicable):
==================================================================
v0.4.4-4...Also seen running on Fedora with v0.4.5-0.1

How reproducible:
=================================
100%

Steps to Reproduce:
=================================
sysconfig.run_string('file { "/var/www/html/sysconfig-test":\n    owner => root, group => root, mode => 440\n}', 0, 'puppet', "dave's $$$")

  
Actual results:
=================================
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/site-packages/qmf/console.py", line 308, in <lambda>
    return lambda *args, **kwargs : self._invoke(name, args, kwargs)
  File "/usr/lib64/python2.6/site-packages/qmf/console.py", line 452, in _invoke
    raise RuntimeError("Timed out waiting for method to respond")
RuntimeError: Timed out waiting for method to respond

Comment 2 Russell Bryant 2011-09-20 19:53:09 UTC
I tried reproducing this with qmf-tool but it didn't happen, can you try?

The method call returns an unknown status since it wasn't able to create a file with that name, but it did provide a response instead of timing out.

qmf: call 2 run_string 'file { "/tmp/sysconfigtest": owner => root, group => root, mode => 440 }' 0 "puppet" "dave's $$$"
Output Parameters:
    Name    Value
    =================
    status  unknown

Comment 3 Dave Johnson 2011-09-20 20:50:44 UTC
Hrm... I get the same timeout exception when using qmf-tool

qmf: call 2 run_string 'file { "/var/www/html/sysconfig-test":\n    owner => root, group => root, mode => 440\n}' 0  puppet "dave's $$$"
Exception in call command: From Remote Agent: {'error_text': 'Timed out waiting for the agent to respond'}

Comment 6 Dave Johnson 2011-09-28 15:23:00 UTC
This looks good now, marking as verified.

Comment 7 Russell Bryant 2011-11-16 22:28:00 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required.

Comment 8 errata-xmlrpc 2011-12-06 11:43:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.