Bug 740056 - SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'getattr' accesses on the file /dev/shm/pulse-shm-2753185353.
Summary: SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'getattr' ac...
Keywords:
Status: CLOSED DUPLICATE of bug 740055
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e761316b81ee53a568b9ae12915...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 19:31 UTC by Mads Kiilerich
Modified: 2011-09-20 20:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-20 20:06:57 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2011-09-20 19:31:35 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-0.rc6.git0.3.fc16.x86_64
reason:         SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'getattr' accesses on the file /dev/shm/pulse-shm-2753185353.
time:           Tue Sep 20 21:31:24 2011

description:
:SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'getattr' accesses on the file /dev/shm/pulse-shm-2753185353.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/dev/shm/pulse-shm-2753185353 default label should be user_tmpfs_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /dev/shm/pulse-shm-2753185353
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that npviewer.bin should be allowed getattr access on the pulse-shm-2753185353 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep npviewer.bin /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
:                              3
:Target Context                unconfined_u:object_r:tmpfs_t:s0
:Target Objects                /dev/shm/pulse-shm-2753185353 [ file ]
:Source                        npviewer.bin
:Source Path                   /usr/lib/nspluginwrapper/npviewer.bin
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           nspluginwrapper-1.4.4-1.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-29.1.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.1.0-0.rc6.git0.3.fc16.x86_64 #1 SMP
:                              Fri Sep 16 12:26:22 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 19 Sep 2011 12:39:18 AM CEST
:Last Seen                     Mon 19 Sep 2011 12:39:18 AM CEST
:Local ID                      d556132c-fc96-4491-9179-a2f419a4ab6f
:
:Raw Audit Messages
:type=AVC msg=audit(1316385558.503:531): avc:  denied  { getattr } for  pid=20379 comm="npviewer.bin" path="/dev/shm/pulse-shm-2753185353" dev=tmpfs ino=340459 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmpfs_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1316385558.503:531): arch=i386 syscall=removexattr per=8 success=yes exit=0 a0=11 a1=ffee3b8c a2=9b8ff4 a3=ffee3c68 items=0 ppid=20358 pid=20379 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=21 comm=npviewer.bin exe=/usr/lib/nspluginwrapper/npviewer.bin subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: npviewer.bin,nsplugin_t,tmpfs_t,file,getattr
:
:audit2allow
:
:#============= nsplugin_t ==============
:allow nsplugin_t tmpfs_t:file getattr;
:
:audit2allow -R
:
:#============= nsplugin_t ==============
:allow nsplugin_t tmpfs_t:file getattr;
:

Comment 1 Daniel Walsh 2011-09-20 20:06:57 UTC

*** This bug has been marked as a duplicate of bug 740055 ***


Note You need to log in before you can comment on or make changes to this bug.