Bug 740089 - aeolus-configure interactive installer is broken.. can not select factory, warehouse, or conductor
Summary: aeolus-configure interactive installer is broken.. can not select factory, wa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Mo Morsi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 21:35 UTC by wes hayutin
Modified: 2012-12-13 19:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-13 19:49:46 UTC


Attachments (Terms of Use)

Description wes hayutin 2011-09-20 21:35:01 UTC
Description of problem:
Select Aeolus Components to Install
1. All
2. None
3. Image Factory
4. Image Warehouse
5. Conductor
Install Aeolus Component: 


** also #2 continues w/ the install.. shouldnt the script just exit?


try to select 3,4,5 just returns to prompt..  busted..


[root@unused ~]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-configure-2.0.2-4.20110916125556git5a94390.fc15.noarch
aeolus-conductor-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-all-0.4.0-0.20110919181505git369190d.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
[root@unused ~]#

Comment 1 Mo Morsi 2011-09-25 15:26:44 UTC
Its not broken, just poorly worded.

The idea is, you can select to install all components or individual components. Unless you select all components, the component selection prompt will be redisplayed until you finish up component selection by selecting 'none'. Perhaps instead of that workflow we should add an additional option such as 'finished' or similar.

Thoughts?

Comment 2 wes hayutin 2011-09-28 16:38:20 UTC
making sure all the bugs are at the right version for future queries

Comment 4 Mo Morsi 2011-12-08 12:44:32 UTC
Patch fixing wording sent to list

https://fedorahosted.org/pipermail/aeolus-devel/2011-December/007232.html

Comment 6 Shveta 2012-01-03 09:21:49 UTC
Select Aeolus Components to Install
1. Select All Components
2. Finish Selection
3. Select Image Factory
4. Select Image Warehouse
Install Aeolus Component: 3


3 and 4 returns to prompt , cannot be selected .

Comment 7 Mo Morsi 2012-01-04 12:25:53 UTC
Not quite sure if I'm following. Selecting 3,4 adds the component to the list to install and returns to this prompt so they can select the next component to install. Selecting 1,2 should finish prompting the user for components to install and move them onto the next prompt (setting up cloud providers).

Again might just be a wording issue, if anyone has an alternate suggestion as how to better word this, feel free to share and I can implement. Else I believe the issue is resolved as is.

Comment 8 wes hayutin 2012-01-16 21:30:01 UTC
this is horribly broken..

selecting 3 or 4 just reprompts the main menu..

Comment 9 Mike Orazi 2012-01-18 18:39:43 UTC
It seems like the initial prompt is essentially acting as a way of accumulating choices the user has made and then eventually kicking off a puppet run.

The flow is pretty confusing, and i"m not sure it is easily resolvable in the 1.0 timeframe.  

I think this is a good feature to continue working on in the upstream version but it probably makes more sense to remove the interactive functionality from 1.0 while working out a good workflow from the user experience point of view.

Comment 10 Mo Morsi 2012-01-19 16:21:31 UTC
(In reply to comment #8)
> this is horribly broken..
> 
> selecting 3 or 4 just reprompts the main menu..

Again I would just say that this is a wording issue. I'm not sure what the best phrasing for this would be, but something along the lines of "select as many aeolus components that you would like to install before continuing on"


(In reply to comment #9)
> It seems like the initial prompt is essentially acting as a way of accumulating
> choices the user has made and then eventually kicking off a puppet run.
> 
> The flow is pretty confusing, and i"m not sure it is easily resolvable in the
> 1.0 timeframe.  
> 
> I think this is a good feature to continue working on in the upstream version
> but it probably makes more sense to remove the interactive functionality from
> 1.0 while working out a good workflow from the user experience point of view.

Ya thats fine to me. Interactive mode was meant to be a standin replacement until we had a cli tool. Now that we have w/ aeolus-cli, the necessity of the interactive mode is reduced

Comment 11 Mo Morsi 2012-01-20 20:16:05 UTC
Patch sent to list 

https://fedorahosted.org/pipermail/aeolus-devel/2012-January/008232.html

Comment 12 Jason Guiditta 2012-01-27 16:11:41 UTC
Pushed to staging

commit b3910e55077e8a1029bc9c4d8093d83255474789
Author: Mo Morsi <mmorsi@redhat.com>
Date:   Wed Jan 25 16:39:22 2012 -0500

    BZ #740089: remove interactive mode for the time being
    
      meant to be a standin replacement until we had aeolus-cli which we do now

Comment 13 Steve Linabery 2012-01-31 22:13:16 UTC
b3910e55077e8a1029bc9c4d8093d83255474789 in aeolus-configure-2.5.0-11

Comment 14 wes hayutin 2012-02-10 22:20:53 UTC
oot@qeblade32 ~]# aeolus-configure --help

USAGE:
aeolus-configure [-d|--debug] [-h|--help] [-v|--verbose] [-p|--profile]

OPTIONS:
   -h | --help       Show this message.
   -d | --debug      Debug logging mode.
   -v | --verbose    Verbose logging mode.
                     Note that you can only set one of the previous two options per run. If both are set,
                     the last one passed in will be honored.
   -p | --profile    Name of profile to use. A comma separated list can be used to specify multiple profiles. 
[root@qeblade32 ~]# aeolus-configure -i

USAGE:
aeolus-configure [-d|--debug] [-h|--help] [-v|--verbose] [-p|--profile]

[root@qeblade32 yum.repos.d]# rpm -qa | grep aeolus
aeolus-conductor-daemons-0.8.0-25.el6.noarch
aeolus-conductor-doc-0.8.0-25.el6.noarch
aeolus-configure-2.5.0-12.el6.noarch
rubygem-aeolus-image-0.3.0-7.el6.noarch
aeolus-conductor-0.8.0-25.el6.noarch
rubygem-aeolus-cli-0.3.0-8.el6.noarch
aeolus-all-0.8.0-25.el6.noarch


Note You need to log in before you can comment on or make changes to this bug.