Bug 74011 - Up2date refuses to update one of my Redhat machines
Up2date refuses to update one of my Redhat machines
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: Security
Depends On:
  Show dependency treegraph
Reported: 2002-09-13 14:39 EDT by Alan Polinsky
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-18 12:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
all of the errors I get when I run up2date (998 bytes, text/plain)
2002-09-13 14:40 EDT, Alan Polinsky
no flags Details

  None (edit)
Description Alan Polinsky 2002-09-13 14:39:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
Up2date was running fine on this machine until there was a problem on the 
internet. From that time on I get a message that RpmError("Couldn't determine 
what version of Red Hat Linux you
are running." I am then told to rebuild the rpm database. I have been in touch 
with mr. Johnson who suggests I raise the issue with the up2date people.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.up2date -uv at the command line or in an x window

Actual Results:   I get the rror I have mentioned. I will attach the complete 
file of the error text

Expected Results:  Up2date should update the machine

Additional info:

Machine is an ibm pentium 133 with 64 megs of memory. I tried to run 
an 'upgrade' from the original cd, and was told that there is a partiton size 
error on my disk. I am afraid to use fdisk to modify the partition; the machine 
is my dsl server for my lan. I want the machine as secure as possible, hence I 
would like to apply all security related patches.
Comment 1 Alan Polinsky 2002-09-13 14:40:27 EDT
Created attachment 76104 [details]
all of the errors I get when I run up2date
Comment 2 Adrian Likins 2002-10-01 17:27:30 EDT
what does `rpm -q redhat-release`

Comment 3 Alan Polinsky 2002-10-01 19:18:33 EDT
package redhat-release is not installed
Comment 4 Alan Polinsky 2002-10-01 21:41:31 EDT
After you gave me the suggestion of the problem, I went to my original install
disks, installed redhat_release, and all is okay again. Thank you very much;
please close the problem.

Note You need to log in before you can comment on or make changes to this bug.