Bug 740123 - "Draft" watermark displays in PDF by default
"Draft" watermark displays in PDF by default
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.7
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-20 22:07 EDT by Michael Doyle
Modified: 2011-09-26 19:54 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-26 19:54:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Doyle 2011-09-20 22:07:13 EDT
Description of problem:

The "Draft" watermark displays in PDF builds even when the <book status="draft"> tag is NOT included.

This means all PDF version include "Draft" by default.

HTML is not affected.


Version-Release number of selected component (if applicable):

publican 2.7-1.fc14


How reproducible:

Always


Steps to Reproduce:
1. Make sure you do not have <book status="draft">
2. Build a PDF
3. Open PDF
  
Actual results:

"Draft" appears in the document.


Expected results:

No watermark in PDF build unless specified with the <book status="draft"> tag.

Additional info:
Comment 1 Stephen Gordon 2011-09-20 22:13:28 EDT
Also reproduced in the F15 package, moved to correct Product/Component.
Comment 2 Jeff Fearn 2011-09-20 22:44:40 EDT
Turns out the HTML and PDF have different logic. Overrode PDF XSL to use same logic as HTML.

Changes applied to publican-2x.

Committed revision 1891.
Comment 3 Ruediger Landmann 2011-09-20 23:24:30 EDT
Verified fixed in publican.noarch 0:2.8-0.fc15.t1

Without the "draft" attribute in the XML, the PDF and HTML versions do not show the watermark. 

Adding the "draft" attribute means that the PDF and HTML versions show the watermark.

Note You need to log in before you can comment on or make changes to this bug.