Bug 740151 - openjdk cannot finish SPECjvm2008 benchmark test
openjdk cannot finish SPECjvm2008 benchmark test
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deepak Bhole
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-21 02:14 EDT by Kirby Zhou
Modified: 2011-09-26 15:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-26 15:42:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the SPECjvm2008 log (23.62 KB, text/xml)
2011-09-21 02:16 EDT, Kirby Zhou
no flags Details

  None (edit)
Description Kirby Zhou 2011-09-21 02:14:28 EDT
Description of problem:



Version-Release number of selected component (if applicable):

SPECjvm2008_1_01_setup.jar
java-1.6.0-openjdk-javadoc-1.6.0.0-1.39.1.9.8.el6_1.x86_64
java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.x86_64
java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.x86_64

How reproducible:

Steps to Reproduce:

# install SPECjvm2008
java -jar SPECjvm2008_1_01_setup.jar
# run test
cd /SPECjvm2008
java -jar -Xmx1024m SPECjvm2008.jar -ikv
# failed

Actual results:

Error in setup of Benchmark.
spec.harness.StopBenchmarkException: Error invoking bmSetupBenchmarkMethod
   at spec.harness.ProgramRunner.invokeBmSetupBenchmark(ProgramRunner.java:185)
   at spec.harness.ProgramRunner.runBenchmark(ProgramRunner.java:301)
   at spec.harness.ProgramRunner.run(ProgramRunner.java:98)
Caused by: java.lang.reflect.InvocationTargetException
   at java.lang.reflect.Method.invoke(libgcj.so.10)
   at spec.harness.ProgramRunner.invokeBmSetupBenchmark(ProgramRunner.java:183)
   ...2 more
Caused by: spec.harness.StopBenchmarkException: Error in setup of crypto.aes.java.security.InvalidParameterException: unsupported key size: 21, valid sizes are: [8, 16, 24]
   at spec.benchmarks.crypto.aes.Main.setupBenchmark(Main.java:165)
   at java.lang.reflect.Method.invoke(libgcj.so.10)
   ...3 more

Warmup (120s) begins: Wed Sep 21 12:48:03 LONT 2011
Warmup (120s) ends:   Wed Sep 21 12:48:03 LONT 2011
Warmup (120s) result:  **NOT VALID**

Errors in benchmark: crypto.aes
   Error in setup of Benchmark.
  [warmup] Harness interruped during measurement period.
  [warmup][bt:1|op:1] spec.harness.StopBenchmarkException: Exception in encrypt for AES/CBC/NoPadding.
Score on crypto.aes:  **NOT VALID**

Benchmark crypto.aes failed. Aborting run.

Results are stored in:
/opt/SPECjvm2008/results/SPECjvm2008.001/SPECjvm2008.001.raw
Generating reports in:
/opt/SPECjvm2008/results/SPECjvm2008.001

(.:31554): Gtk-WARNING **: cannot open display:
[root@djt-17-109-v06 SPECjvm2008]# head -25 resYou have new mail in /var/spool/mail/root

Expected results:

Done the benchmark without any error.

Additional info:

java-1.6.0-sun and java-1.6.0-ibm can do it well.
Comment 1 Kirby Zhou 2011-09-21 02:16:14 EDT
Created attachment 524136 [details]
the SPECjvm2008 log
Comment 2 Kirby Zhou 2011-09-21 02:17:01 EDT
You can get SPECjvm2008 from http://www.spec.org/download.html
Comment 3 Kirby Zhou 2011-09-21 02:23:10 EDT
My mistake, the report is invalid.
Comment 5 Deepak Bhole 2011-09-26 15:42:22 EDT
Closing as per comment #3

To clarify further, the run is using GCJ and not OpenJDK. 'alternatives --config java' should be run to set the right JRE first.

Note You need to log in before you can comment on or make changes to this bug.