Bug 740152 - Invalid handling of qpid.max_size
Summary: Invalid handling of qpid.max_size
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 2.0
Hardware: All
OS: Linux
high
medium
Target Milestone: 3.0
: ---
Assignee: Gordon Sim
QA Contact: Leonid Zhaldybin
URL:
Whiteboard:
Depends On:
Blocks: 740154
TreeView+ depends on / blocked
 
Reported: 2011-09-21 06:18 UTC by John Lau
Modified: 2018-11-14 10:28 UTC (History)
5 users (show)

Fixed In Version: 0.12
Doc Type: Bug Fix
Doc Text:
It was discovered that the broker retrieved the maximum queue size option as a uint32, even though it should be a uint64. The maximum value expressible for the aggregate queue size in bytes was needlessly limited, which prevented large queue sizes from being configured. The broker now correctly retrieves the size as a uint64. Any value expressible as a uint64 is now valid as the maximum queue size (in bytes).
Clone Of:
: 740154 (view as bug list)
Environment:
Last Closed: 2014-09-24 15:03:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-3140 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Description John Lau 2011-09-21 06:18:17 UTC
Description of problem:
A customer reported that they hit the problem in MRG-2.0 and MRG-1.3 that similar to the one mentioned in here:
https://issues.apache.org/jira/browse/QPID-3140

So they would like to see if we can backport the fix to MRG-2.0 and MRG-1.3.

Version-Release number of selected component (if applicable):
qpid-cpp-mrg in MRG-2.0

How reproducible:
Always

Steps to Reproduce:
1. Set queue limit to a number > 4G
  
Actual results:
Fail

Expected results:
Success

Comment 8 Leonid Zhaldybin 2013-12-17 09:34:12 UTC
Tested on RHEL6.5. This issue has been fixed.

Packages used for testing:

python-qpid-0.22-8.el6.noarch
python-qpid-qmf-0.22-24.el6.x86_64
qpid-cpp-client-0.22-29.el6.x86_64
qpid-cpp-client-devel-0.22-29.el6.x86_64
qpid-cpp-client-devel-docs-0.22-29.el6.noarch
qpid-cpp-client-rdma-0.22-29.el6.x86_64
qpid-cpp-client-ssl-0.22-29.el6.x86_64
qpid-cpp-server-0.22-29.el6.x86_64
qpid-cpp-server-devel-0.22-29.el6.x86_64
qpid-cpp-server-ha-0.22-29.el6.x86_64
qpid-cpp-server-rdma-0.22-29.el6.x86_64
qpid-cpp-server-ssl-0.22-29.el6.x86_64
qpid-cpp-server-store-0.22-29.el6.x86_64
qpid-cpp-server-xml-0.22-29.el6.x86_64
qpid-proton-c-0.5-9.el6.x86_64
qpid-qmf-0.22-24.el6.x86_64
qpid-tools-0.22-7.el6.noarch

-> VERIFIED

Comment 10 errata-xmlrpc 2014-09-24 15:03:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.