Bug 740157 - err: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]/ensure: change from stopped to running failed: Could not start Service[imagefactory] in aeolus-configure
Summary: err: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]/ensure: change ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Ian McLeod
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 06:39 UTC by Aziza Karol
Modified: 2011-11-08 17:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-07 12:50:04 UTC


Attachments (Terms of Use)

Description Aziza Karol 2011-09-21 06:39:30 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
[root@dell-pe1950-03 ~]# aeolus-configure -d  -v
Launching aeolus configuration recipe...
info: Applying configuration version '1316586239'
notice: /File[/data]/ensure: created
notice: /File[/data/db]/ensure: created
notice: /Stage[main]/Aeolus::Image-factory/File[/var/tmp/imagefactory-mock]/ensure: created
notice: /Stage[main]/Apache/Exec[permit-http-networking]/returns: executed successfully
info: FileBucket adding {md5}2c8eb8faf2e09f55fb2b46b54ea6707b
info: /File[/etc/ntp.conf]: Filebucketed /etc/ntp.conf to puppet with sum 2c8eb8faf2e09f55fb2b46b54ea6707b
notice: /File[/etc/ntp.conf]/content: content changed '{md5}2c8eb8faf2e09f55fb2b46b54ea6707b' to '{md5}2dfb9420ebf32c7d97f86526fe6c21e8'
info: /File[/etc/ntp.conf]: Scheduling refresh of Service[ntpd]
info: FileBucket adding {md5}32fdc5cdf3f181e7b6987410cf607d15
info: /File[/etc/ntp/step-tickers]: Filebucketed /etc/ntp/step-tickers to puppet with sum 32fdc5cdf3f181e7b6987410cf607d15
notice: /File[/etc/ntp/step-tickers]/content: content changed '{md5}32fdc5cdf3f181e7b6987410cf607d15' to '{md5}2dfb9420ebf32c7d97f86526fe6c21e8'
info: /File[/etc/ntp/step-tickers]: Scheduling refresh of Service[ntpd]
notice: /Stage[main]/Ntp::Client/Service[ntpd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Ntp::Client/Service[ntpd]: Triggered 'refresh' from 2 events
info: FileBucket adding {md5}74475874677f1c689de937e4ef8c89f1
info: /File[/etc/qpidd.conf]: Filebucketed /etc/qpidd.conf to puppet with sum 74475874677f1c689de937e4ef8c89f1
notice: /File[/etc/qpidd.conf]/content: content changed '{md5}74475874677f1c689de937e4ef8c89f1' to '{md5}3b762fe02ab4c355304d933bad24aee0'
notice: /Stage[main]/Aeolus::Image-factory/Service[qpidd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Apache/Service[httpd]/ensure: ensure changed 'stopped' to 'running'
info: FileBucket adding {md5}8129c1ef2030ef66c0437b5d49115c3d
info: /File[/etc/httpd/conf.d/aeolus-conductor.conf]: Filebucketed /etc/httpd/conf.d/aeolus-conductor.conf to puppet with sum 8129c1ef2030ef66c0437b5d49115c3d
notice: /File[/etc/httpd/conf.d/aeolus-conductor.conf]/content: content changed '{md5}8129c1ef2030ef66c0437b5d49115c3d' to '{md5}0903c79c5c139b3b29ec930849890b41'
info: /File[/etc/httpd/conf.d/aeolus-conductor.conf]: Scheduling refresh of Exec[reload-apache]
notice: /Stage[main]/Apache/Exec[reload-apache]: Triggered 'refresh' from 1 events
notice: /Stage[main]/Postgres::Server/Exec[pginitdb]/returns: executed successfully
info: /Stage[main]/Postgres::Server/Exec[pginitdb]: Scheduling refresh of Service[postgresql]
info: FileBucket adding {md5}32962db9efb8ba7ba027226555303f7e
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Filebucketed /var/lib/pgsql/data/pg_hba.conf to puppet with sum 32962db9efb8ba7ba027226555303f7e
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/content: content changed '{md5}32962db9efb8ba7ba027226555303f7e' to '{md5}2d3f1f2e30c9b188961b1acd3ade3b8b'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/owner: owner changed 'postgres' to 'root'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/group: group changed 'postgres' to 'root'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/mode: mode changed '600' to '644'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/seluser: seluser changed 'unconfined_u' to 'system_u'
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
notice: /Stage[main]/Postgres::Server/Service[postgresql]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Postgres::Server/Service[postgresql]: Triggered 'refresh' from 6 events
notice: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: executed successfully
notice: /File[/root/.aeolus-cli]/ensure: defined content as '{md5}3480897435f68ac21b0e4ae48fd5b38a'
notice: /Stage[main]/Aeolus::Conductor/Selinux::Mode[permissive]/Exec[set_selinux_permissive]/returns: executed successfully
notice: /File[/etc/condor/config.d/10deltacloud.config]/ensure: defined content as '{md5}f8266a8f5eba4717579d5e14edee0a74'
notice: /Stage[main]/Aeolus::Conductor/Service[condor]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Iwhd/Service[mongod]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Image-factory/Service[libvirtd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Iwhd/Service[iwhd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:                                  Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0xec[create-bucket-aeolus]/returns: 
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Service[conductor-dbomatic]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Conductor/Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Conductor/Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]/returns: executed successfully
notice: /File[/var/lib/aeolus-conductor/production.seed]/ensure: created
err: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]/ensure: change from stopped to running failed: Could not start Service[imagefactory]: Execution of '/sbin/service imagefactory start' returned 1:  at /usr/share/aeolus-configure/modules/aeolus/manifests/image-factory.pp:69
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: User admin registered
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]/returns: Granting administrator privileges for admin...
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Service[aeolus-conductor]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Login[admin]/Web_request[admin-conductor-login]/post: post changed '' to 'https://localhost/conductor/user_session'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp2]/Web_request[hwp-hwp2]/post: post changed '' to 'https://localhost/conductor/hardware_profiles'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp1]/Web_request[hwp-hwp1]/post: post changed '' to 'https://localhost/conductor/hardware_profiles'
notice: /Stage[main]/Aeolus::Deltacloud::Core/Service[deltacloud-core]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-west-1]/Web_request[provider-ec2-us-west-1]/post: post changed '' to 'https://localhost/conductor/providers'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-east-1]/Web_request[provider-ec2-us-east-1]/post: post changed '' to 'https://localhost/conductor/providers'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[mock]/Web_request[provider-mock]/post: post changed '' to 'https://localhost/conductor/providers'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider::Account[mockuser]/Web_request[provider-account-mockuser]/post: post changed '' to 'https://localhost/conductor/provider_accounts'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Logout[admin]/Web_request[admin-conductor-logout]/post: post changed '' to 'https://localhost/conductor/logout'
info: Creating state file /var/lib/puppet/state/state.yaml
notice: Finished catalog run in 78.48 seconds

  

Additional info:[root@dell-pe1950-03 ~]# rpm -qa | grep aeolus
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
aeolus-conductor-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-configure-2.0.2-4.20110916125556git5a94390.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-all-0.4.0-0.20110919181505git369190d.fc15.noarch

[root@dell-pe1950-03 ~]# rpm -qa | grep imagefactory
imagefactory-0.6.1-1.fc15.noarch
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.fc15.noarch

Comment 2 Dave Johnson 2011-09-21 14:24:42 UTC
[root@hp-z600-01 nodes]# service imagefactory start
Starting imagefactory (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
[FAILED]
[root@hp-z600-01 nodes]# systemctl status
Too few arguments.
[root@hp-z600-01 nodes]# tail -5 /var/log/messages
Sep 21 10:21:44 hp-z600-01 /usr/bin/deltacloudd[2083]: 127.0.0.1 - - [21/Sep/2011 10:21:44] "GET /api?force_auth=1 HTTP/1.1" 401 21 0.2349
Sep 21 10:21:54 hp-z600-01 systemd[1]: imagefactory.service: control process exited, code=exited status=1
Sep 21 10:21:54 hp-z600-01 systemd[1]: Unit imagefactory.service entered failed state.
Sep 21 10:24:00 hp-z600-01 systemd[1]: imagefactory.service: control process exited, code=exited status=1
Sep 21 10:24:00 hp-z600-01 systemd[1]: Unit imagefactory.service entered failed state.

Comment 3 Dave Johnson 2011-09-21 14:27:11 UTC
[root@hp-z600-01 nodes]# systemctl status imagefactory.service
imagefactory.service - LSB: start and stop Image Factory qmf agent
	  Loaded: loaded (/etc/rc.d/init.d/imagefactory)
	  Active: failed since Wed, 21 Sep 2011 10:24:00 -0400; 2min 40s ago
	 Process: 3046 ExecStart=/etc/rc.d/init.d/imagefactory start (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/imagefactory.service

Comment 5 Mike Orazi 2011-09-21 15:59:35 UTC
This appears to be an issue with the underlying imagefactory service.

Comment 6 Steve Loranz 2011-09-21 18:15:42 UTC
A dependency was left out of the 0.6.1 package.  If you want to get past this before 0.6.2 comes out, you can use easy_install or pip to install bottle.

Comment 7 wes hayutin 2011-09-21 22:47:03 UTC
Thank you very much for the quick fix!!



[root@unused yum.repos.d]# aeolus-configure -d -v
Launching aeolus configuration recipe...
dnsdomainname: Name or service not known
info: Applying configuration version '1316645028'
info: FileBucket adding {md5}32fdc5cdf3f181e7b6987410cf607d15
info: /File[/etc/ntp/step-tickers]: Filebucketed /etc/ntp/step-tickers to puppet with sum 32fdc5cdf3f181e7b6987410cf607d15
notice: /File[/etc/ntp/step-tickers]/content: content changed '{md5}32fdc5cdf3f181e7b6987410cf607d15' to '{md5}2dfb9420ebf32c7d97f86526fe6c21e8'
info: /File[/etc/ntp/step-tickers]: Scheduling refresh of Service[ntpd]
info: FileBucket adding {md5}e5de90852f279b2f85f9aa47160a2598
info: /File[/etc/ntp.conf]: Filebucketed /etc/ntp.conf to puppet with sum e5de90852f279b2f85f9aa47160a2598
notice: /File[/etc/ntp.conf]/content: content changed '{md5}e5de90852f279b2f85f9aa47160a2598' to '{md5}2dfb9420ebf32c7d97f86526fe6c21e8'
info: /File[/etc/ntp.conf]: Scheduling refresh of Service[ntpd]
notice: /Stage[main]/Ntp::Client/Service[ntpd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Ntp::Client/Service[ntpd]: Triggered 'refresh' from 2 events
notice: /File[/data]/ensure: created
notice: /File[/data/db]/ensure: created
notice: /Stage[main]/Postgres::Server/Exec[pginitdb]/returns: executed successfully
info: /Stage[main]/Postgres::Server/Exec[pginitdb]: Scheduling refresh of Service[postgresql]
notice: /Stage[main]/Aeolus::Image-factory/File[/var/tmp/imagefactory-mock]/ensure: created
notice: /Stage[main]/Aeolus::Conductor/Selinux::Mode[permissive]/Exec[set_selinux_permissive]/returns: executed successfully
notice: /Stage[main]/Aeolus::Iwhd/Service[mongod]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Image-factory/Service[libvirtd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Apache/Exec[permit-http-networking]/returns: executed successfully
notice: /Stage[main]/Apache/Service[httpd]/ensure: ensure changed 'stopped' to 'running'
info: FileBucket adding {md5}8129c1ef2030ef66c0437b5d49115c3d
info: /File[/etc/httpd/conf.d/aeolus-conductor.conf]: Filebucketed /etc/httpd/conf.d/aeolus-conductor.conf to puppet with sum 8129c1ef2030ef66c0437b5d49115c3d
notice: /File[/etc/httpd/conf.d/aeolus-conductor.conf]/content: content changed '{md5}8129c1ef2030ef66c0437b5d49115c3d' to '{md5}0903c79c5c139b3b29ec930849890b41'
info: /File[/etc/httpd/conf.d/aeolus-conductor.conf]: Scheduling refresh of Exec[reload-apache]
notice: /Stage[main]/Apache/Exec[reload-apache]: Triggered 'refresh' from 1 events
notice: /File[/root/.aeolus-cli]/ensure: defined content as '{md5}3480897435f68ac21b0e4ae48fd5b38a'
info: FileBucket adding {md5}74475874677f1c689de937e4ef8c89f1
info: /File[/etc/qpidd.conf]: Filebucketed /etc/qpidd.conf to puppet with sum 74475874677f1c689de937e4ef8c89f1
notice: /File[/etc/qpidd.conf]/content: content changed '{md5}74475874677f1c689de937e4ef8c89f1' to '{md5}3b762fe02ab4c355304d933bad24aee0'
notice: /Stage[main]/Aeolus::Image-factory/Service[qpidd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Deltacloud::Core/Service[deltacloud-core]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully
info: FileBucket adding {md5}32962db9efb8ba7ba027226555303f7e
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Filebucketed /var/lib/pgsql/data/pg_hba.conf to puppet with sum 32962db9efb8ba7ba027226555303f7e
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/content: content changed '{md5}32962db9efb8ba7ba027226555303f7e' to '{md5}2d3f1f2e30c9b188961b1acd3ade3b8b'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/owner: owner changed 'postgres' to 'root'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/group: group changed 'postgres' to 'root'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/mode: mode changed '600' to '644'
notice: /File[/var/lib/pgsql/data/pg_hba.conf]/seluser: seluser changed 'unconfined_u' to 'system_u'
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
info: /File[/var/lib/pgsql/data/pg_hba.conf]: Scheduling refresh of Service[postgresql]
notice: /Stage[main]/Postgres::Server/Service[postgresql]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Postgres::Server/Service[postgresql]: Triggered 'refresh' from 6 events
notice: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Service[aeolus-conductor]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Conductor/Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Conductor/Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]/returns: executed successfully
notice: /File[/var/lib/aeolus-conductor/production.seed]/ensure: created
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: User admin registered
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]/returns: Granting administrator privileges for admin...
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Login[admin]/Web_request[admin-conductor-login]/post: post changed '' to 'https://localhost/conductor/user_session'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp1]/Web_request[hwp-hwp1]/post: post changed '' to 'https://localhost/conductor/hardware_profiles'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[mock]/Web_request[provider-mock]/post: post changed '' to 'https://localhost/conductor/providers'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider::Account[mockuser]/Web_request[provider-account-mockuser]/post: post changed '' to 'https://localhost/conductor/provider_accounts'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-west-1]/Web_request[provider-ec2-us-west-1]/post: post changed '' to 'https://localhost/conductor/providers'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-east-1]/Web_request[provider-ec2-us-east-1]/post: post changed '' to 'https://localhost/conductor/providers'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp2]/Web_request[hwp-hwp2]/post: post changed '' to 'https://localhost/conductor/hardware_profiles'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Logout[admin]/Web_request[admin-conductor-logout]/post: post changed '' to 'https://localhost/conductor/logout'
notice: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]/enable: enable changed 'false' to 'true'
notice: /Stage[main]/Aeolus::Conductor/Service[conductor-dbomatic]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Iwhd/Service[iwhd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:                                  Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0xec[create-bucket-aeolus]/returns: 
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: executed successfully
info: Creating state file /var/lib/puppet/state/state.yaml
notice: Finished catalog run in 61.16 seconds
[root@unused yum.repos.d]# 
[root@unused yum.repos.d]# 
[root@unused yum.repos.d]# /etc/init.d/imagefactory status
imagefactory.service - LSB: start and stop Image Factory qmf agent
	  Loaded: loaded (/etc/rc.d/init.d/imagefactory)
	  Active: active (running) since Wed, 21 Sep 2011 14:54:13 -0400; 3h 51min ago
	Main PID: 4586 (imagefactory)
	  CGroup: name=systemd:/system/imagefactory.service
		  └ 4586 /usr/bin/python /usr/bin/imagefactory --qmf --debug
[root@unused yum.repos.d]# 
[root@unused yum.repos.d]# 
[root@unused yum.repos.d]# aeolus-check-services 

Checking mongod ...
 Success: mongod.service - SYSV: Starts and stops the MongDB daemon that handles all database requests.
	  Loaded: loaded (/etc/rc.d/init.d/mongod)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:54 -0400; 2min 4s ago
	Main PID: 5192 (mongod)
	  CGroup: name=systemd:/system/mongod.service
		  └ 5192 /usr/bin/mongod --quiet -f /etc/mongodb.conf run

Checking iwhd ...
 Success: iwhd.service - LSB: image warehouse daemon
	  Loaded: loaded (/etc/rc.d/init.d/iwhd)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:51 -0400; 1min 7s ago
	Main PID: 5979 (iwhd)
	  CGroup: name=systemd:/system/iwhd.service
		  └ 5979 iwhd -c /etc/iwhd/conf.js -d localhost:27017 -l /v...

Checking postgresql ...
 Success: postgresql.service - LSB: start and stop PostgreSQL server
	  Loaded: loaded (/etc/rc.d/init.d/postgresql)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:05 -0400; 1min 53s ago
	Main PID: 5697 (postmaster)
	  CGroup: name=systemd:/system/postgresql.service
		  ├ 5697 /usr/bin/postmaster -p 5432 -D /var/lib/pgsql/data...
		  ├ 5699 postgres: logger process   
		  ├ 5701 postgres: writer process   
		  ├ 5702 postgres: wal writer process   
		  ├ 5703 postgres: autovacuum launcher process   
		  ├ 5704 postgres: stats collector process   
		  └ 5787 postgres: aeolus conductor ::1(50780) idle

Checking httpd ...
 Success: httpd.service - LSB: start and stop Apache HTTP Server
	  Loaded: loaded (/etc/rc.d/init.d/httpd)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:56 -0400; 2min 3s ago
	Main PID: 5379 (httpd)
	  CGroup: name=systemd:/system/httpd.service
		  ├ 5379 /usr/sbin/httpd
		  ├ 5433 /usr/sbin/httpd
		  ├ 5434 /usr/sbin/httpd
		  ├ 5435 /usr/sbin/httpd
		  ├ 5436 /usr/sbin/httpd
		  ├ 5437 /usr/sbin/httpd
		  ├ 5438 /usr/sbin/httpd
		  ├ 5439 /usr/sbin/httpd
		  └ 5440 /usr/sbin/httpd

Checking qpidd ...
 Success: qpidd.service - LSB: start or stop qpidd
	  Loaded: loaded (/etc/rc.d/init.d/qpidd)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:58 -0400; 2min 0s ago
	Main PID: 5467 (qpidd)
	  CGroup: name=systemd:/system/qpidd.service
		  └ 5467 /usr/sbin/qpidd --data-dir /var/lib/qpidd --daemon...

Checking deltacloud-core ...
 Success: deltacloud-core.service - LSB: Deltacloud Core API deamon
	  Loaded: loaded (/etc/rc.d/init.d/deltacloud-core)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:58 -0400; 2min 0s ago
	Main PID: 5529 (deltacloudd)
	  CGroup: name=systemd:/system/deltacloud-core.service
		  └ 5529 /usr/bin/ruby /usr/bin/deltacloudd -i mock -e prod...

Checking libvirtd ...
 Success: libvirtd.service - LSB: daemon for libvirt virtualization API
	  Loaded: loaded (/etc/rc.d/init.d/libvirtd)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:55 -0400; 2min 3s ago
	Main PID: 5248 (libvirtd)
	  CGroup: name=systemd:/system/libvirtd.service
		  ├ 5248 libvirtd --daemon
		  └ 5345 /usr/sbin/dnsmasq --strict-order --bind-interfaces...

Checking aeolus-conductor ...
 Success: aeolus-conductor.service - SYSV: aeolus-conductor is the primary server process for the
	  Loaded: loaded (/etc/rc.d/init.d/aeolus-conductor)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:29 -0400; 1min 30s ago
	Main PID: 5768 (thin)
	  CGroup: name=systemd:/system/aeolus-conductor.service
		  └ 5768 thin server (127.0.0.1:3000)                      ...

Checking conductor-dbomatic ...
 Success: conductor-dbomatic.service - SYSV: conductor-dbomatic populates the Aeolus Conductor db from
	  Loaded: loaded (/etc/rc.d/init.d/conductor-dbomatic)
	  Active: active (running) since Wed, 21 Sep 2011 18:44:51 -0400; 1min 8s ago
	Main PID: 5929 (dbomatic)
	  CGroup: name=systemd:/system/conductor-dbomatic.service
		  └ 5929 /usr/bin/ruby /usr/share/aeolus-conductor/dbomatic...

Checking imagefactory ...
 Success: imagefactory.service - LSB: start and stop Image Factory qmf agent
	  Loaded: loaded (/etc/rc.d/init.d/imagefactory)
	  Active: active (running) since Wed, 21 Sep 2011 14:54:13 -0400; 3h 51min ago
	Main PID: 4586 (imagefactory)
	  CGroup: name=systemd:/system/imagefactory.service
		  └ 4586 /usr/bin/python /usr/bin/imagefactory --qmf --debu...

Checking ntpd ...
 Success: ntpd.service - Network Time Service
	  Loaded: loaded (/lib/systemd/system/ntpd.service)
	  Active: active (running) since Wed, 21 Sep 2011 18:43:52 -0400; 2min 7s ago
	Main PID: 5107 (ntpd)
	  CGroup: name=systemd:/system/ntpd.service
		  └ 5107 /usr/sbin/ntpd -n -u ntp:ntp -g
[root@unused yum.repos.d]# 


[root@unused yum.repos.d]# rpm -qa | grep factory 
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.fc15.noarch
imagefactory-0.6.1_5_gfd3a5f2-1.fc15.noarch
[root@unused yum.repos.d]# rpm -qa |grep configure
aeolus-configure-2.0.2-4.20110921102958gitcaa9608.fc15.noarch


Note You need to log in before you can comment on or make changes to this bug.