Bug 740168 - virsh send-key and qemu-monitor-command does not work
Summary: virsh send-key and qemu-monitor-command does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Eric Blake
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 745723 (view as bug list)
Depends On: 738411
Blocks: 725559
TreeView+ depends on / blocked
 
Reported: 2011-09-21 07:51 UTC by Huang Wenlong
Modified: 2013-10-20 21:44 UTC (History)
11 users (show)

Fixed In Version: libvirt-0.9.4-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:32:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Huang Wenlong 2011-09-21 07:51:57 UTC
Description of problem:
virsh send-key  does not work
virsh qemu-monitor-command  does not work  too 

Version-Release number of selected component (if applicable):
libvirt-0.9.4-12.el6.x86_64
qemu-kvm-0.12.1.2-2.192.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start a guest
2. send key to guest from host
# virsh send-key t62 KEY_N
error: command 'send-key' requires<keycode>  option



# virsh qemu-monitor-command t mouse_move 200 200 --hmp
error: command 'qemu-monitor-command' requires <cmd> option


Actual results:
send-key does not work


Expected results:
send-key  work


Additional info:

libvirt-0.9.4-10.el6.x86_64  send-key works well
so this bug is a regression

Comment 3 Eric Blake 2011-09-21 14:48:30 UTC
regression introduced by patch to bug 738411

Comment 4 Eric Blake 2011-09-21 14:55:18 UTC
Upstream patch proposed:
https://www.redhat.com/archives/libvir-list/2011-September/msg00847.html

Comment 7 yanbing du 2011-09-26 08:32:07 UTC
Test with libvirt-0.9.4-13.el6.x86_64, both virsh send-key and virsh qemu-monitor-command command work well.
Move to Verified.

Comment 8 Jiri Denemark 2011-10-13 09:12:44 UTC
*** Bug 745723 has been marked as a duplicate of this bug. ***

Comment 9 linuxdev-ofuku 2011-10-20 01:58:02 UTC
We were asked to verify the fix in BZ#745723.
And then our engineers verified that "virsh send-key" worked on 
RHEL6.2 snapshot1.
Thanks.

Best regards,
M Hanaki

Comment 10 errata-xmlrpc 2011-12-06 11:32:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.