Bug 74018 - gconf2 should own all directories it creates
Summary: gconf2 should own all directories it creates
Status: CLOSED DUPLICATE of bug 74017
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: GConf2   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 20:30 UTC by Enrico Scholz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 20:30:45 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /etc/gconf/2 /etc/gconf/2/path
| file /etc/gconf/2 is not owned by any package
| GConf2-1.2.1-1

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

GConf2-1.2.1-1


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that GConf2 is uninstalled completely
   (rm -rf /etc/gconf/2)
3. rpm -U GConf2-1.2.1-1.i386.rpm
4. ls -l /etc/gconf/2
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e GConf2-1.2.1-1


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 22:24 /etc/gconf/2
* files can not be found/read at 5 and
* /etc/gconf/2 still exists after 6.

Comment 1 Havoc Pennington 2002-12-20 00:00:25 UTC

*** This bug has been marked as a duplicate of 74017 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:49:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.