Bug 740190 - gdm in dualhead when notebook lid is closed
Summary: gdm in dualhead when notebook lid is closed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 692776
TreeView+ depends on / blocked
 
Reported: 2011-09-21 08:59 UTC by Karel Srot
Modified: 2011-12-06 14:39 UTC (History)
4 users (show)

Fixed In Version: xorg-x11-server-1.10.4-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 14:39:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1602 normal SHIPPED_LIVE xorg-x11-server and tigervnc bug fix and enhancement update 2011-12-06 00:51:12 UTC

Description Karel Srot 2011-09-21 08:59:58 UTC
Description of problem:

I have just updated to latest RHEL6.2 compose from RHEL6.1 and now I am facing following issue.
I am using docking station for my T500 with external display. My notebook is closed all the time, I am using just external display. Display configuration is set to "mirror" in Display config dialog. 

During the system start up all messages are printed on my external display (this is fine) but when gdm/xserver starts, is switches do dualhead and my primary display (with login dialog) is the closed (notebook) one. On my external display I can see just the background.

When I open the lid and login to gnome display switches to mirror mode as configured and everything is fine. Till the next reboot.

This forces me to open my netbook lid just because of login.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep xorg
xorg-x11-xauth-1.0.2-7.1.el6.x86_64
xorg-x11-proto-devel-7.6-12.el6.noarch
xorg-x11-drv-vesa-2.3.0-2.el6.x86_64
xorg-x11-drv-nouveau-0.0.16-13.20110719gitde9d1ba.el6.x86_64
xorg-x11-drv-vmware-11.0.3-1.el6.x86_64
xorg-x11-drv-dummy-0.3.4-1.el6.x86_64
xorg-x11-drv-i128-1.3.4-1.el6.x86_64
xorg-x11-drv-ast-0.91.10-1.el6.x86_64
xorg-x11-drv-aiptek-1.4.1-2.el6.x86_64
xorg-x11-drivers-7.3-13.3.el6.x86_64
xorg-x11-drv-vmmouse-12.7.0-1.el6.x86_64
xorg-x11-server-common-1.10.4-1.el6.x86_64
xorg-x11-drv-ati-6.14.2-6.el6.x86_64
xorg-x11-drv-sis-0.10.3-1.el6.x86_64
xorg-x11-drv-nv-2.1.18-2.el6.x86_64
xorg-x11-font-utils-7.2-11.el6.x86_64
xorg-x11-drv-mach64-6.9.0-1.el6.x86_64
xorg-x11-drv-cirrus-1.3.2-2.el6.x86_64
xorg-x11-xinit-1.0.9-13.el6.x86_64
xorg-x11-drv-evdev-2.6.0-2.el6.x86_64
xorg-x11-utils-7.4-8.el6.x86_64
xorg-x11-drv-siliconmotion-1.7.5-1.el6.x86_64
xorg-x11-drv-intel-2.16.0-1.el6.x86_64
xorg-x11-drv-glint-1.2.5-1.el6.x86_64
xorg-x11-drv-rendition-4.2.4-1.el6.x86_64
xorg-x11-drv-synaptics-1.4.1-3.el6.x86_64
xorg-x11-fonts-misc-7.2-9.1.el6.noarch
xorg-x11-drv-ati-firmware-6.14.2-6.el6.noarch
xorg-x11-drv-elographics-1.3.0-2.el6.x86_64
xorg-x11-drv-hyperpen-1.4.1-2.el6.x86_64
xorg-x11-drv-r128-6.8.1-3.el6.x86_64
xorg-x11-drv-qxl-0.0.14-6.el6.x86_64
xorg-x11-drv-s3virge-1.10.4-2.el6.x86_64
xorg-x11-xkb-utils-7.4-6.el6.x86_64
xorg-x11-server-Xephyr-1.10.4-1.el6.x86_64
xorg-x11-drv-xgi-1.6.0-10.el6.x86_64
xorg-x11-drv-sisusb-0.9.4-1.el6.x86_64
xorg-x11-drv-tdfx-1.4.3-2.el6.x86_64
xorg-x11-drv-voodoo-1.2.4-1.el6.x86_64
xorg-x11-drv-openchrome-0.2.904-4.el6.x86_64
xorg-x11-server-utils-7.5-5.1.el6.x86_64
xorg-x11-drv-mutouch-1.3.0-2.el6.x86_64
xorg-x11-drv-mouse-1.7.0-4.el6.x86_64
xorg-x11-drv-i740-1.3.2-2.el6.x86_64
xorg-x11-drv-wacom-0.10.5-13.el6.x86_64
xorg-x11-drv-savage-2.3.2-1.el6.x86_64
xorg-x11-drv-keyboard-1.6.0-1.el6.x86_64
xorg-x11-drv-void-1.4.0-1.el6.x86_64
xorg-x11-drv-v4l-0.2.0-4.el6.x86_64
xorg-x11-drv-penmount-1.5.0-2.el6.x86_64
xorg-x11-drv-apm-1.2.3-2.el6.x86_64
xorg-x11-server-Xorg-1.10.4-1.el6.x86_64
xorg-x11-drv-fpit-1.4.0-2.el6.x86_64
xorg-x11-drv-fbdev-0.4.2-2.el6.x86_64
xorg-x11-drv-trident-1.3.4-1.el6.x86_64
xorg-x11-drv-acecad-1.5.0-3.el6.x86_64
xorg-x11-drv-mga-1.4.13-2.el6.x86_64


How reproducible:
always for me

Steps to Reproduce:
1. closed notebook in docking station with external display connected
2. start the system
3. gdm login dialog doesn't appear on external display
  
Expected results:
login dialog on external display

Additional info:
please, let me know what logs do you need.

Comment 2 Adam Jackson 2011-10-13 18:19:51 UTC
Works for me as of xorg-x11-server-1.10.4-4.el6.

MODIFIED.

Comment 4 Karel Srot 2011-10-17 06:52:18 UTC
Hi, I can confirm this is fixed with xorg-x11-server-1.10.4-4.el6.
Thank you.

Comment 8 errata-xmlrpc 2011-12-06 14:39:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1602.html


Note You need to log in before you can comment on or make changes to this bug.