Bug 740209 - [abrt] Zim-0.53-1.fc14: index.py:1483:get_all_pages_index:AssertionError: BUG: could not find path in index
[abrt] Zim-0.53-1.fc14: index.py:1483:get_all_pages_index:AssertionError: BUG...
Status: CLOSED DUPLICATE of bug 750055
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:d84cb75c
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-21 05:51 EDT by Niranjan Mallapadi Raghavender
Modified: 2011-12-16 04:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-16 04:58:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.02 KB, text/plain)
2011-09-21 05:51 EDT, Niranjan Mallapadi Raghavender
no flags Details

  None (edit)
Description Niranjan Mallapadi Raghavender 2011-09-21 05:51:03 EDT
abrt version: 1.1.18
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/zim
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.14-96.fc14.x86_64
package: Zim-0.53-1.fc14
reason: index.py:1483:get_all_pages_index:AssertionError: BUG: could not find path in index
release: Fedora release 14 (Laughlin)
time: 1316598383
uid: 500

backtrace
-----
index.py:1483:get_all_pages_index:AssertionError: BUG: could not find path in index

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 761, in on_open_page
    self.treeview.select_page(path)
  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 635, in select_page
    model.select_page(path)
  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 55, in select_page
    for treepath in self.get_treepaths(mypath):
  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 494, in get_treepaths
    pageindex = self.index.get_all_pages_index(p)
  File "/usr/lib/python2.7/site-packages/zim/index.py", line 1483, in get_all_pages_index
    assert False, 'BUG: could not find path in index'
AssertionError: BUG: could not find path in index

Local variables in innermost frame:
i: 75
cursor: <sqlite3.Cursor object at 0x18b9ce0>
path: <IndexPath: corby>
self: <Index object at 0x17d5500 (zim+index+Index at 0x184f800)>
row: <sqlite3.Row object at 0x18aa550>

How to reproduce
-----
1.Not sure
2.
3.
Comment 1 Niranjan Mallapadi Raghavender 2011-09-21 05:51:06 EDT
Created attachment 524173 [details]
File: backtrace
Comment 2 Robin Lee 2011-12-16 04:58:46 EST

*** This bug has been marked as a duplicate of bug 750055 ***

Note You need to log in before you can comment on or make changes to this bug.