Bug 740229 - network printer not detected
Summary: network printer not detected
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 10:55 UTC by Frank Zimmermann
Modified: 2012-08-07 15:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 15:48:50 UTC


Attachments (Terms of Use)

Description Frank Zimmermann 2011-09-21 10:55:21 UTC
Description of problem:
Hello I have a HP LaserJet 3055 on my home network. With CUPS/HPLIP/HPIJS installed I tried to configure the printer after a clean install from the live DVD. The config tool was not able to locate the printer all. 

Version-Release number of selected component (if applicable):
1.3.5

How reproducible:


Steps to Reproduce:
1. tried again (see below)
2.
3.
  
Actual results:
no printer detected

Expected results:
find printer, let my choose the drinter driver, configre it and let me print/scan

Additional info:
I'm not 100% sure wether this is related to config-system-printer since further packages are involved and I did the following steps to fianlly resolve the issue:
1. I tried hp-setup -i which didn't find the printer either.
2. I configured CUPS with the web interface on localhost:631 which went well till the point I tried to print where I got the error message that the printer was not connected. So I deleted the printer.
3. I installed hplip-gui and this tool found my printer and was able to configure it. Printing and scanning now works perfectly well.

Comment 1 Tim Waugh 2011-09-21 11:28:44 UTC
How did you start the config tool?  Was it e.g. System Settings -> Printers?

Comment 2 Frank Zimmermann 2011-09-21 11:45:37 UTC
Yes, that's how I started the config tool.

Comment 3 Tim Waugh 2011-09-21 12:09:28 UTC
OK -- that's not system-config-printer.

What does 'lpinfo -l -v' say?  Also, what is the hostname or IP address of the network printer?

Comment 4 Frank Zimmermann 2011-09-21 12:44:20 UTC
here's the output from lpinfo -l -v

Gerät: URI = socket
        Klasse = network
        Info = AppSocket/HP JetDirect
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = lpd
        Klasse = network
        Info = LPD/LPR-Host oder -Drucker
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = https
        Klasse = network
        Info = Internet-Druckerprotokoll (https)
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = http
        Klasse = network
        Info = Internet-Druckerprotokoll (http)
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = ipp
        Klasse = network
        Info = Internet-Druckerprotokoll (ipp)
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = scsi
        Klasse = direct
        Info = SCSI-Drucker
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = hp
        Klasse = direct
        Info = HP Printer (HPLIP)
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = beh
        Klasse = network
        Info = Backend Error Handler
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 
Gerät: URI = hpfax
        Klasse = direct
        Info = HP Fax (HPLIP)
        Hersteller und Modell = Unknown
        Geräte-ID = 
        Standort = 

It's a private network and I configured the router in a way to provide a fix IP address to the printer

Comment 5 Tim Waugh 2011-09-21 13:39:25 UTC
Thanks.  Now what does this say? (Use the hostname/IP address of the printer)

/usr/lib/cups/backend/snmp $HOSTNAME

Comment 6 Frank Zimmermann 2011-09-23 18:50:11 UTC
network socket://192.168.2.104 "HP LaserJet 3055" "HP LaserJet 3055" "MFG:Hewlett-Packard;CMD:PJL,PML,MLC,POSTSCRIPT,PCLXL,PCL;MDL:HP LaserJet 3055;CLS:PRINTER;DES:Hewlett-Packard LaserJet 3055;MEM:MEM=53MB;1284.4DL:4d,4e,1;COMMENT:RES=1200x1;" "Boise, ID, USA"

Comment 8 Tim Waugh 2011-09-26 09:52:14 UTC
Add maintainer to CC list.  Marek: does the control center printer panel look at any other protocol than IPP for network printer detection yet? (It really needs to...)

Comment 9 Marek Kašík 2011-09-26 13:26:59 UTC
Hi,

in F15, g-c-c uses httpConnectEncrypt() for connection to specified host and cups-pk-helper's method DevicesGet for searching for new printers. I've added support for the SNMP backend in F16 for the specified host but I haven't planned to add it to F15. Btw, I'm working on samba support.

Marek

Comment 10 Marek Kašík 2011-09-29 14:12:40 UTC
Hi,

I've committed the SNMP support to upstream's gnome-3-0 branch (the patch is not as complicated as I thought). So wait for next stable release of control-center-3.0.x (but the last one was at May).

Regards

Marek

Comment 11 Fedora End Of Life 2012-08-07 15:48:54 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.