Bug 740232 - root.log regression (no yum output) in 1.1.14
Summary: root.log regression (no yum output) in 1.1.14
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 11:31 UTC by Henrik Nordström
Modified: 2011-10-16 18:29 UTC (History)
2 users (show)

Fixed In Version: mock-1.1.15-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-02 23:00:33 UTC


Attachments (Terms of Use)

Description Henrik Nordström 2011-09-21 11:31:13 UTC
Description of problem:

With the update to 1.1.14 root.log no longer contains output from yum

Version-Release number of selected component (if applicable):

mock-1.1.14-1.fc15

How reproducible:

always

Steps to Reproduce:
1. mock -r fedora-15-x86_64 somepackage.src.rpm
2.
3.
  
Actual results:

Build progresses fine, but root.log contains absolutlely no output from yum, which means there is no clues to what packages got installed in the buildroot.

This have been observed first on armv7hl and now on x86_64 as well.

Expected results:

yum output logs as usual.

Additional info:

1.1.12 works.

This regression was reported with negative karma on the mock-1.1.14-1.fc15 update long before it got pushed to stabe. Silently ignored ;(

Comment 1 Clark Williams 2011-09-21 16:29:47 UTC
Sorry I missed it before pushing. 

Looks like it *might* be fallout from the mock -> mockbuild namespace conversion.

Comment 2 Clark Williams 2011-09-23 18:53:37 UTC
I believe this is fixed in the upcoming 1.1.15 release. If not please reopen.

Comment 3 Fedora Update System 2011-09-23 20:54:59 UTC
mock-1.1.15-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mock-1.1.15-1.fc15

Comment 4 Fedora Update System 2011-09-23 20:56:01 UTC
mock-1.1.15-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.15-1.el6

Comment 5 Fedora Update System 2011-09-23 20:56:54 UTC
mock-1.0.22-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.22-1.el5

Comment 6 Fedora Update System 2011-09-23 20:57:47 UTC
mock-1.1.15-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mock-1.1.15-1.fc14

Comment 7 Henrik Nordström 2011-09-23 20:59:20 UTC
Looks fine. Thanks!

Comment 8 Fedora Update System 2011-09-24 21:59:13 UTC
Package mock-1.1.15-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.15-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mock-1.1.15-1.el6
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-10-02 22:59:32 UTC
mock-1.1.15-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-10-02 23:07:56 UTC
mock-1.1.15-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-10-16 18:27:33 UTC
mock-1.0.22-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-10-16 18:29:17 UTC
mock-1.1.15-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.