Bug 74024 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: alchemist (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 16:31 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version: 1.0.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 10:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 16:31:37 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /etc/alchemist /etc/alchemist/namespace
| file /etc/alchemist is not owned by any package
| alchemist-1.0.24-4

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

alchemist-1.0.24-4


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that alchemist is uninstalled completely
   (rm -rf /etc/alchemist)
3. rpm -U alchemist-1.0.24-4.i386.rpm
4. ls -l /etc/alchemist
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e alchemist-1.0.24-4


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 21:58 /etc/alchemist
* files can not be found/read at 5 and
* /etc/alchemist still exists after 6.

Note You need to log in before you can comment on or make changes to this bug.