Bug 740300 - cancel_sync issues with on repos that have automatic sync schedules.
Summary: cancel_sync issues with on repos that have automatic sync schedules.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: Sprint 29
Assignee: Jason Connor
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 15:08 UTC by Preethi Thomas
Modified: 2014-03-31 01:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Preethi Thomas 2011-09-21 15:08:39 UTC
Description of problem:

Looks like cancel sync does not cancel syncs of repos that has automatic sync schedules.


Version-Release number of selected component (if applicable):


How reproducible:
[root@preethi ~]# rpm -q pulp
pulp-0.0.232-1.fc15.noarch


Steps to Reproduce:
1. Create a repo with automatic sync schedule
2. Run a manual repo sync
3. Try to cancel the above repo sync

Comment 1 Jason Connor 2011-10-11 06:14:26 UTC
the sync cancel used to always "cancel" the scheduled sync instead of the running one

changed the sync task search criteria to look for running or immediate and waiting tasks

Comment 2 Jeff Ortel 2011-10-13 00:49:14 UTC
build: 0.238

Comment 3 Preethi Thomas 2011-10-14 14:28:27 UTC
verified


[root@preethi ~]# rpm -qa pulp
pulp-0.0.238-1.fc15.noarch
[root@preethi ~]# pulp-admin -u admin -p admin repo update --id=f14 --start=2011-10-14T10:30:00-04:00:00 --interval=P1DT1H5M
Successfully updated repository [ f14 ]

[root@preethi ~]# pulp-admin repo sync --id=f14 -F
Sync for repository f14 started
Sync: Canceled

Item Details: 
Tree_File: 7/7
Rpm: 2766/2766

Comment 4 Preethi Thomas 2012-02-24 20:17:33 UTC
Pulp v1.0 is released
Closed Current Release.

Comment 5 Preethi Thomas 2012-02-24 20:18:32 UTC
Pulp v1.0 is released.


Note You need to log in before you can comment on or make changes to this bug.