Bug 740318 - Using generated kickstart file to install RHEL 6.1 fails because of "repo" directive
Summary: Using generated kickstart file to install RHEL 6.1 fails because of "repo" di...
Keywords:
Status: CLOSED DUPLICATE of bug 738577
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.1
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 15:40 UTC by nico.martin
Modified: 2011-09-21 17:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 17:56:24 UTC


Attachments (Terms of Use)
kickstart (830 bytes, text/plain)
2011-09-21 15:40 UTC, nico.martin
no flags Details
anaconda.log (8.48 KB, text/plain)
2011-09-21 15:41 UTC, nico.martin
no flags Details

Description nico.martin 2011-09-21 15:40:25 UTC
Created attachment 524233 [details]
kickstart

Description of problem:
Using the kickstart file /root/anaconda-ks.cfg generated by anaconda to install RHEL6U1 on a machine fails with the error :

"Unable to read package metadata. This may be due to a missing repodata directory. Please ensure that your install tree has been correctly generated.

Cannot retrieve repository metadata (repomd.xml) for repository: Red Hat Enterprise Linux. Please verify its path and try again"

Removing the following directive in the kickstart makes the installation work :
repo --name="Red Hat Enterprise Linux" --baseurl=cdrom:sr0 --cost=100


Version-Release number of selected component (if applicable):
RHEL6U1

How reproducible:
Systematic

Steps to Reproduce:
1.Install RHEL6U1 using only the install DVD
2.Use the resulting kickstart /root/anaconda-ks.cfg to install another machine (again with the DVD)
3.The installation fails with the aforementioned error "Unable to read package metadata ..."
  
Actual results:
Using the kickstart file generated by anaconda results in an error during installation.

Expected results:
The kickstart file generated by anaconda results in a successful installation.

Additional info:
Attached : kickstart and anaconda.log

Comment 1 nico.martin 2011-09-21 15:41:05 UTC
Created attachment 524234 [details]
anaconda.log

Comment 3 David Cantrell 2011-09-21 17:56:24 UTC

*** This bug has been marked as a duplicate of bug 738577 ***


Note You need to log in before you can comment on or make changes to this bug.