Bug 740321 - Power control operations still appear to complete against systems not associated with a lab controller
Summary: Power control operations still appear to complete against systems not associa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.7
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ---
Assignee: Steven Lawrance
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 15:59 UTC by Derrich Hafemann
Modified: 2019-05-22 13:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-26 07:16:30 UTC


Attachments (Terms of Use)

Description Derrich Hafemann 2011-09-21 15:59:11 UTC
Description of problem:

When decommissioning a Beaker system recently, we noticed that after the system was disassociated with the lab controller, the power control buttons were still displayed. The buttons appeared to still be functional - the UI reported that the command was enqueued, but the action never showed up in the power mini-log, nor the overall system history.

Looking at beakerd.log and cobbler.log as I was playing with this, the system in question never appeared in the logs.

So, power control actions aren't being taken against systems with no lab controller associated with them - that's good, since it's the behavior we want. The only real problem here is very minor, and it's just that the UI presents the power control buttons as if they were still available, when they're not.

Version-Release number of selected component (if applicable): beaker-0.7.1-2.el5


How reproducible: 100%

Steps to Reproduce:
1. Change lab controller association of a given system to 'None'
2. Note that power control buttons are still present
3. Start tailing logs on both beaker scheduler and lab controller
4. Click any of the power action buttons in the Web UI
  
Actual results:

The power operation is reported as enqueued, and no error is thrown back to the user letting them know that the operation won't complete.


Expected results:

Either the power control buttons shouldn't be displayed for systems that aren't attached to a lab controller, or the user should be given an error message telling them that their power action won't complete.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.