Bug 74039 - [libxml-devel] Does not work when installed with an umask of 077 and messes filesystem
Summary: [libxml-devel] Does not work when installed with an umask of 077 and messes f...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libxml (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Jay Turner
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 20:34 UTC by Enrico Scholz
Modified: 2015-01-08 00:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 22:25:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 20:34:10 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /usr/share/gnome-xml /usr/share/gnome-xml/html
| file /usr/share/gnome-xml is not owned by any package
| libxml-devel-1.8.17-5

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

libxml-devel-1.8.17-5


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that libxml-devel is uninstalled completely
   (rm -rf /usr/share/gnome-xml)
3. rpm -U libxml-devel-1.8.17-5.i386.rpm
4. ls -l /usr/share/gnome-xml
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e libxml-devel-1.8.17-5


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 21:48 /usr/share/gnome-xml
* files can not be found/read at 5 and
* /usr/share/gnome-xml still exists after 6.

Comment 1 Daniel Veillard 2004-08-26 22:25:18 UTC
libxml version 1 is deprecated. It is there only for backward
compatibility reasons. I do not intend to put any maintainance time
on it unless it is critical. IMHO libxml-devel shouldn't even be
packaged at all, everything should build against libxml2, the fork
was done 4 years ago.
                                                                     
          
Daniel



Note You need to log in before you can comment on or make changes to this bug.