Bug 740454 - Please add back cjkuni-uming-fonts and cjkuni-ukai-fonts to DVD ISO
Summary: Please add back cjkuni-uming-fonts and cjkuni-ukai-fonts to DVD ISO
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 734301
TreeView+ depends on / blocked
 
Reported: 2011-09-22 05:59 UTC by Peng Wu
Modified: 2014-03-17 03:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-23 18:48:52 UTC


Attachments (Terms of Use)
Update fonts group (2.41 KB, patch)
2011-09-23 02:47 UTC, Peng Wu
no flags Details | Diff

Description Peng Wu 2011-09-22 05:59:45 UTC
Description of problem:
cjkuni-uming-fonts and cjkuni-ukai-fonts are preferred fonts for Traditional Chinese users.
The two fonts are not included in the DVD image.
After installation, some users found that no cjkuni-uming-fonts or cjkuni-ukai-fonts for Traditional Chinese.
Please add back cjkuni-uming-fonts and cjkuni-ukai-fonts to solve bug #734301.


Version-Release number of selected component (if applicable):
Fedora-16-Beta-x86_64-DVD.iso RC1.

How reproducible:
Install Fedora 16 DVD with Chinese (Traditional) Language selected.


Actual results:
traditional-chinese-support package group is installed,
cjkuni-uming-fonts and cjkuni-ukai-fonts are not installed.

Expected results:
traditional-chinese-support package group is installed,
cjkuni-uming-fonts and cjkuni-ukai-fonts are installed.

Additional info:
Refer Bug: Bug 734301 - zh_TW] zh_TW does not install the fonts listed on fonts list

Comment 1 Akira TAGOH 2011-09-22 11:42:06 UTC
apparently the lang support in comps isn't referred for composing and cjkuni fonts are marked as "optional" in the fonts group. actually when installing f16 beta RC1 from the above iso, I didn't get those packages in Traditional Chinese support installed.

I guess we may have an option to get this improved:

1) change cjkuni-uming-fonts to "default" in the fonts group

2) add the lang support back when composing

1) may affects the Live image size. I'm not sure how many spaces we still have in Live. I prefer 2) to take an action for this because the lang support contains the lang specific packages that yum-langpacks can't deal with. but here may be wrong place to request it?

FWIW I've seen Jens's proposal to get rid of the lang support from the comps and I may be missing more discussion about it though, I don't know any reason why we dropped the lang support from composing DVD iso in f16.

Comment 2 Bill Nottingham 2011-09-22 18:57:53 UTC
If they're the preferred fonts for Chinese, they should be the default in that group. Feel free to send/commit a fonts patch to update the defaults for Chinese (and any other language where they don't match...)

Comment 3 Peng Wu 2011-09-23 02:47:49 UTC
Created attachment 524533 [details]
Update fonts group

Here are the patch for Chinese fonts.
wqy-zenhei-fonts and cjkuni-uming-fonts are "default" now.
wqy-zenhei-fonts are for Simplified Chinese, cjkuni-uming-fonts are for Traditional Chinese.

Comment 4 Bill Nottingham 2011-09-23 18:48:52 UTC
Added, thanks!


Note You need to log in before you can comment on or make changes to this bug.