Bug 740455 - block I/O error when install guest on qcow2 image size > 2T ,cluster_size=512
Summary: block I/O error when install guest on qcow2 image size > 2T ,cluster_size=512
Keywords:
Status: CLOSED DUPLICATE of bug 676753
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Kevin Wolf
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 06:10 UTC by daiwei
Modified: 2013-01-10 00:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-07 16:21:46 UTC


Attachments (Terms of Use)

Description daiwei 2011-09-22 06:10:52 UTC
Description of problem:


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.190.el6.x86_64
2.6.32-198.el6.x86_64

How reproducible:
2/2

Steps to Reproduce:
1.create a qcow2 image size > 2T with cluster_size=512
# qemu-img create -f qcow2 /home/qcow2/RHEL-Server-6.2-64_big.qcow2 2500G -o cluster_size=512
Formatting '/home/qcow2/RHEL-Server-6.2-64_big.qcow2', fmt=qcow2 size=2684354560000 encryption=off cluster_size=512 
# qemu-img check /home/qcow2/RHEL-Server-6.2-64_big.qcow2 
No errors were found on the image.
# qemu-img info qcow2/RHEL-Server-6.2-64_big.qcow2 
image: qcow2/RHEL-Server-6.2-64_big.qcow2
file format: qcow2
virtual size: 2.4T (2684354560000 bytes)
disk size: 627M
cluster_size: 512

2.install a guest OS
# /usr/libexec/qemu-kvm -M rhel6.2.0 -enable-kvm -name RHEL-Server-6.2-64_big -smp 2 -m 2G -uuid `uuidgen` -boot menu=on -drive file=/home/qcow2/RHEL-Server-6.2-64_big.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none,aio=native,media=disk,werror=stop,rerror=stop -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=44:37:E6:5E:A3:F6 -drive file=/home/RHEL6.2-Server-x86_64.iso,if=none,media=cdrom,readonly=on,format=raw,id=drive-ide1-0-0 -device ide-drive,drive=drive-ide1-0-0,id=ide1-0-0,bootindex=1 -vnc :2 -balloon none -monitor stdio

3.
  
Actual results:
After step2, when formatting disk image, guest stopped due to:
(qemu) block I/O error in device 'drive-ide0-0-0': Unknown error 2038412288 (2038412288)

#qemu-img check qcow2/RHEL-Server-6.2-64_big.qcow2
Leaked cluster 2932994 refcount=1 reference=0
Leaked cluster 2932995 refcount=1 reference=0
...
Leaked cluster 4407295 refcount=1 reference=0

295 leaked clusters were found on the image.
This means waste of disk space, but no harm to data



Expected results:


Additional info:

Comment 2 Dor Laor 2011-09-22 08:29:01 UTC
What happens with default cluster size (of 64k)?

Comment 3 daiwei 2011-09-22 08:46:16 UTC
With default cluster size 64k,no issue.

Comment 5 Kevin Wolf 2011-12-07 16:21:46 UTC

*** This bug has been marked as a duplicate of bug 676753 ***


Note You need to log in before you can comment on or make changes to this bug.