Bug 74047 - gnome-vfs2-extras should own more directories
gnome-vfs2-extras should own more directories
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs2-extras (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
http://www.tu-chemnitz.de/~ensc/dirch...
: EasyFix, Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-09-13 16:35 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 10:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 16:35:24 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /etc/gnome-vfs-2.0/modules /etc/gnome-vfs-2.0/modules/extra-modules.conf
| file /etc/gnome-vfs-2.0/modules is not owned by any package
| gnome-vfs2-extras-0.99.3-1

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

gnome-vfs2-extras-0.99.3-1


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that gnome-vfs2-extras is uninstalled completely
   (rm -rf /etc/gnome-vfs-2.0/modules)
3. rpm -U gnome-vfs2-extras-0.99.3-1.i386.rpm
4. ls -l /etc/gnome-vfs-2.0/modules
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e gnome-vfs2-extras-0.99.3-1


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 22:10 /etc/gnome-vfs-2.0/modules
* files can not be found/read at 5 and
* /etc/gnome-vfs-2.0/modules still exists after 6.
Comment 1 Alexander Larsson 2003-02-25 10:03:51 EST
This directory is owned by gnome-vfs2 in at least gnome-vfs2-2.2.2-3.

Note You need to log in before you can comment on or make changes to this bug.