Bug 740510 - audio recording migration: recording in progress lost after migration
Summary: audio recording migration: recording in progress lost after migration
Keywords:
Status: CLOSED DUPLICATE of bug 740493
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 09:50 UTC by Yonit Halperin
Modified: 2014-01-21 00:00 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-03 10:29:46 UTC


Attachments (Terms of Use)
Record audio error during migration (426.28 KB, image/png)
2011-09-23 10:04 UTC, Qunfang Zhang
no flags Details

Description Yonit Halperin 2011-09-22 09:50:38 UTC
Description of problem:
Windows 7 guest. 
(1) start recording audio using Microsoft sound recorder
(2) perform migration
(3) continue the recording after migration
(4) save the recording to file
(5) open the file (close the sound recorder first #740493)
result: only the after migration recording was saved.

Version-Release number of selected component (if applicable):

qemu-kvm-0.12.1.2-2.192.el6 (audio params: "-device intel-hda,id=sound0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0")
 
spice-server-0.8.2-3

Comment 2 Qunfang Zhang 2011-09-23 10:04:05 UTC
Hi, Yonit
I am trying to reproduce this bug. But during migration, I always meet a problem and can not continue record the audio. The screenshot will be attached.
The error will happen after several minutes if DO NOT implement migraion but it will happen at once when I begin the migration, so blocking me to reproduce the bug.
Do you know what's the problem?

Command line I used:
/usr/libexec/qemu-kvm -M rhel6.2.0 -cpu cpu64-rhel6,+x2apic -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,threads=1 -name RHEL6 -uuid 5820cc38-984e-49ed-b451-ea627b09ddda -monitor stdio -rtc base=localtime -boot c -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x4 -drive file=/media/win7-32-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop -device ide-drive,bus=ide.0,unit=0,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:10:20:58,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/tmp/foo,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -usb -spice port=5930,disable-ticketing -global qxl-vga.vram_size=67108864 -k en-us -vga qxl -device intel-hda,id=sound0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0

Comment 3 Qunfang Zhang 2011-09-23 10:04:49 UTC
Created attachment 524572 [details]
Record audio error during migration

Comment 4 Yonit Halperin 2011-09-28 05:15:08 UTC
(In reply to comment #2)
> Hi, Yonit
> I am trying to reproduce this bug. But during migration, I always meet a
> problem and can not continue record the audio. The screenshot will be attached.
> The error will happen after several minutes if DO NOT implement migraion but it
> will happen at once when I begin the migration, so blocking me to reproduce the
> bug.
> Do you know what's the problem?
> 
> Command line I used:
> /usr/libexec/qemu-kvm -M rhel6.2.0 -cpu cpu64-rhel6,+x2apic -enable-kvm -m 1024
> -smp 2,sockets=2,cores=1,threads=1 -name RHEL6 -uuid
> 5820cc38-984e-49ed-b451-ea627b09ddda -monitor stdio -rtc base=localtime -boot c
> -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x4
> -drive
> file=/media/win7-32-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop
> -device ide-drive,bus=ide.0,unit=0,drive=drive-virtio-disk0,id=virtio-disk0
> -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device
> virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:10:20:58,bus=pci.0,addr=0x3
> -chardev socket,id=charchannel0,path=/tmp/foo,server,nowait -device
> virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm
> -chardev spicevmc,id=charchannel1,name=vdagent -device
> virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0
> -usb -spice port=5930,disable-ticketing -global qxl-vga.vram_size=67108864 -k
> en-us -vga qxl -device intel-hda,id=sound0 -device
> hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0

Hi,
I don't know what the problem is. However, in https://bugzilla.redhat.com/show_bug.cgi?id=740493#c2 Marc-andre said something about a known bug that the disk is filled quickly during recording.

Comment 5 Gerd Hoffmann 2011-10-28 10:38:15 UTC
Should be retested once bug 740493 is fixed.

Comment 7 Gerd Hoffmann 2011-12-12 10:06:19 UTC
Can you re-test with RHEL-6.2 please?

Comment 8 Qunfang Zhang 2012-03-16 09:40:38 UTC
Hi,all
I re-test with rhel6.3 version and the issue does not exist.
Package tested:
kernel-2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.246.el6.x86_64 

Steps:
1. Boot a win7 guest with the following CLI:
/usr/libexec/qemu-kvm -M rhel6.3.0 -cpu Conroe -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,threads=1 -name win7-32 -uuid 5820cc38-984e-49ed-b451-ea627b09ddda -monitor stdio -rtc base=localtime -boot c -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x4 -drive file=/mnt/win7-32-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop -device ide-drive,bus=ide.0,unit=0,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:10:20:58,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/tmp/foo,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -usb -spice port=5930,disable-ticketing -global qxl-vga.vram_size=67108864 -k en-us -vga qxl -device intel-hda,id=sound0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0

2.Start recording audio using Microsoft sound recorder

3.Perform migration

4.Continue the recording after migration 

5.Save the recording to file

6.Open the file

Result: After step 6, I heard that the sound content before and after migration is all saved.

And I borrow one rhel6.2 host to try to reproduce it. But the problem mentioned in comment 2, 3 and 4 still blocks me. Anyway, for the latest rhel6.3 host, problem mentioned in comment 2 does not exist and this bug is verified pass.

Comment 10 Gerd Hoffmann 2012-07-03 10:29:46 UTC
Fixed in 6.3 according to comment 8.
Most likely a dup of bug 740493.

*** This bug has been marked as a duplicate of bug 740493 ***


Note You need to log in before you can comment on or make changes to this bug.