Bug 740514 - rsyslog not able to connect to smtp port
Summary: rsyslog not able to connect to smtp port
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks: 747120
TreeView+ depends on / blocked
 
Reported: 2011-09-22 10:19 UTC by Karel Srot
Modified: 2011-12-06 10:19 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.7.19-114.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:19:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1511 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2011-12-06 00:39:17 UTC

Description Karel Srot 2011-09-22 10:19:13 UTC
Description of problem:

rsyslog ommail ommail module is included in RHEL6.2 (RFE bz 702314).
rsyslog is not able to connect to snmp port

# grep -i avc /var/log/audit/audit.log
type=AVC msg=audit(1316686239.531:42300): avc:  denied  { name_connect } for  pid=18080 comm=72733A6D61696E20513A526567 dest=25 scontext=unconfined_u:system_r:syslogd_t:s0 tcontext=system_u:object_r:smtp_port_t:s0 tclass=tcp_socket
type=AVC msg=audit(1316686316.371:42301): avc:  denied  { name_connect } for  pid=18241 comm=72733A6D61696E20513A526567 dest=25 scontext=unconfined_u:system_r:syslogd_t:s0 tcontext=system_u:object_r:smtp_port_t:s0 tclass=tcp_socket


Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-109.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. configure rsyslog to send logs via mail

Comment 1 Karel Srot 2011-09-22 10:21:37 UTC
I mean smtp port, not snmp. sorry. 
When I allow this with semodule -M, rsyslog works fine and mails are delivered.

Comment 2 Miroslav Grepl 2011-09-22 11:20:13 UTC
We need to add it.

Comment 3 Daniel Walsh 2011-09-22 13:03:00 UTC
This should be by boolean.  I would not want rsyslog just mailing off log files.

Comment 4 Miroslav Grepl 2011-09-22 13:11:51 UTC
"logging_syslogd_can_sendmail"

is fine?

Comment 5 Daniel Walsh 2011-09-22 13:25:27 UTC
Sure default to false.

Comment 6 Miroslav Grepl 2011-10-03 14:02:44 UTC
Fixed in selinux-policy-3.7.19-114.el6

Comment 10 errata-xmlrpc 2011-12-06 10:19:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1511.html


Note You need to log in before you can comment on or make changes to this bug.