Bug 74053 - Epson Stylus C80 Not An Option For Printing In GIMP
Epson Stylus C80 Not An Option For Printing In GIMP
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gimp-print (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 18:00 EDT by James Keeble
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-14 04:20:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Keeble 2002-09-13 18:00:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020912

Description of problem:
I am trying to print from the GIMP to an Epson Stylus C80.  I've used the CUPS
web interface to configure local USB printing.  This works fine for other apps
such as Mozilla, a2ps, or using lpr directly.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start the GIMP, load picture to print.
2. Choose File -> Print
3. Choose Setup button in Printer Settings area.
4. Search in vain for the Epson Stylus C80.  Can't find it, so leave printer
model as Postscript Level 2

Actual Results:  Raw postscript text comes out from the printer.  It appears to
be valid postscript, and if I use gv to view the output sent to the printer in
/var/spool/cups, it looks OK.

Expected Results:  The picture should be printed.

Additional info:

Versions of relevent packages:
gimp-print-utils-4.2.1-5
gimp-print-cups-4.2.1-5
gimp-print-4.2.1-5
cups-drivers-1.9-1.20020617.6
cups-drivers-pnm2ppa-1.9-1.20020617.6
cups-1.1.15-9
cups-libs-1.1.15-9

I'm not sure what's going on here.  The C80 is listed as an option in the CUPS
web interface.  There appears to be two copies of the C80 PPD file:
/usr/share/cups/model/foomatic/Epson/Epson-Stylus_C80-gimp-print-cups.ppd.gz
from the cups-drivers RPM and 
/usr/share/cups/model/C/escp2-c80.ppd.gz
from the gimp-print-cups RPM.

The command line being used in gimp-print is:
lp -s -dc80 -oraw
Comment 1 Tim Waugh 2002-09-13 18:05:20 EDT
The 'print' plug-in in the GIMP package is an older version of gimp-print; the 
'gimp-print' package doesn't actually provide that plug-in at the moment. 
 
The fix is to make it do that, and then the C80 will be listed.
Comment 2 James Keeble 2002-09-13 22:01:57 EDT
I guess I'm confused because the C80 was first supported in version 4.2.0 of
gimp-print, at least in the regular releases from gimp-print.sourceforge.net. 
And, seeing the file /usr/share/cups/model/C/escp2-c80.ppd.gz from
gimp-print-cups also made me think it should be working.
Comment 3 Tim Waugh 2002-09-14 04:20:50 EDT
Indeed. (4.0.5 is the version supplied in the gimp package.)
Comment 4 Tim Waugh 2002-11-06 07:21:43 EST
This is fixed in gimp-1.2.3-11 and gimp-print-4.2.1-6, which will shortly appear
in rawhide.

Note You need to log in before you can comment on or make changes to this bug.