Bug 740581 - Closing/Opening laptop lid in dual head doesn't change screen conf.
Summary: Closing/Opening laptop lid in dual head doesn't change screen conf.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.2
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
: 747005 (view as bug list)
Depends On: 740892
Blocks: 748554
TreeView+ depends on / blocked
 
Reported: 2011-09-22 14:55 UTC by Jiri Koten
Modified: 2011-12-06 14:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 14:39:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1602 normal SHIPPED_LIVE xorg-x11-server and tigervnc bug fix and enhancement update 2011-12-06 00:51:12 UTC

Description Jiri Koten 2011-09-22 14:55:52 UTC
Description of problem:
I'm using T500 in dock connected to an external display, dual head in span mode. In rhel6.1 when I closed the lid, the screen conf. changed - Laptop display was disconnected I had only external display active. After opening the lid I got span mode again. 

This doesn't work in rhel6.2 anymore, when I close the lid, laptop screen is still on and desktop is still in span mode, i.e. I have some windows on the closed laptop screen . 
Also when I manually turn the laptop screen off and then open the lid, screen is still off.     

HW:T500 (2241B48)
Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
[8086:2a42] (rev 07)

Version-Release number of selected component (if applicable):
xorg-x11-drv-vesa-2.3.0-2.el6
xorg-x11-server-Xorg-1.10.4-3.el6
kernel-2.6.32-199.el6

How reproducible:
100%

Steps to Reproduce:
1. log into desktop session using span mode
2. close the laptop lid
3. open the laptop lid
  
Actual results:
screen conf. doesn't change

Expected results:
closing/opening the lid should trigger change in screen conf.

Additional info:

Comment 4 Adam Jackson 2011-09-22 17:36:57 UTC
/wrists

So.  The X server no longer proxies lid state into output connectivity, because doing so caused resume failures.  The session does listen for lid events, but does not inspect lid state itself.  gnome-power-manager implements two possible states where the lid can be closed but the system stays running: "Do Nothing", and "Blank Screen".  Do Nothing does indeed do nothing; it does not update the screen configuration to be external-only.  Blank Screen does indeed blank the screen, which blanks both screens, which isn't horribly useful.

So the problem is deciding where to fix this.  The server apparently ought not look at lid state.  We could change that and reintroduce some resume failures.  Or we could patch Gnome to have Do Nothing not do nothing.  Both are kind of ugly.

Comment 5 Adam Jackson 2011-09-23 16:46:02 UTC
After some digging, it's not as dire as I'd thought.

The resume failure I noted above turns out to be a rather subtle deadlock in gnome-screensaver, triggerable with the lid state proxy patch applied (but theoretically possible to trigger in other scenarios).  I have a patch which resolves this deadlock, though it still needs review from the screensaver maintainer since for all I know it could have security implications.

Once that's merged, I believe we can re-merge the lid state proxy, at which point this bug will probably be fixed.

Comment 7 Adam Jackson 2011-10-13 17:05:01 UTC
Built xorg-x11-server-1.10.4-4.el6

MODIFIED

Comment 10 Adam Jackson 2011-10-19 13:54:04 UTC
*** Bug 747005 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2011-12-06 14:39:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1602.html


Note You need to log in before you can comment on or make changes to this bug.