Bug 740639 - Bug in 8.14.5: two AUTH lines
Summary: Bug in 8.14.5: two AUTH lines
Keywords:
Status: CLOSED DUPLICATE of bug 716628
Alias: None
Product: Fedora
Classification: Fedora
Component: sendmail
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 19:11 UTC by Piergiorgio Sartor
Modified: 2011-09-25 17:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-25 17:53:27 UTC


Attachments (Terms of Use)

Description Piergiorgio Sartor 2011-09-22 19:11:37 UTC
Description of problem:
I'm *severely* hit by this bug:

http://newsgroups.derkeiler.com/Archive/Comp/comp.mail.sendmail/2011-05/msg00030.html

It seems there is an issue, in the latest greatest sendmail, preventing it to work with smarthosts which reply with two AUTH lines.
The mailing list thread explains quite well the situation and there is even a proposed patch (not clear if it works).

Version-Release number of selected component (if applicable):
sendmail-8.14.5-1.fc15
sendmail-cf-8.14.5-1.fc15

How reproducible:
Always.

Steps to Reproduce:
1.
Setup smarthost relay (remote server must answer with two AUTH lines).
2.
Send email to localhost (any client) relying on "sendmail" for the delivery to the smarthost.
  
Actual results:
The remote server replies with an error and the email bounces back.

Expected results:
The email should be delivered without problems.

Additional info:
I downgraded to 8.14.4-20.fc15 and everything is working fine, now.
Nevertheless, it would be wise to have the latest version fixed or reverted in the repository to the previous one.

Thanks a lot,

bye,

pg

Comment 1 Piergiorgio Sartor 2011-09-22 19:23:24 UTC
OK, I just noticed that koji as an update which should fix this issue.
I searched bugzilla, not koji, and the bug did not show up because it is ON_QA...

I guess this one can be marked as duplicate of #716628 without problems.

BTW, when we will get the sendmail update to the normal channels?

Thanks again and sorry for the noise,

bye,

pg

Comment 2 Jaroslav Škarvada 2011-09-25 17:53:27 UTC
No problem. The update is currently in updates testing repo. You can install it from there, e.g. something like:
 yum --enablerepo=updates-testing update sendmail
should work.

Sendmail is marked as critical path component, thus karma from proven testers is required in bodhi (https://admin.fedoraproject.org/updates/FEDORA-2011-12797) to get it into stable and this process can take a long time. I guess that most of the testers focus now on F16. You can try to ask on QA mailing list (test@lists.fedoraproject.or) or ask on IRC (#fedora-qa at freenode) to speed things up.

*** This bug has been marked as a duplicate of bug 716628 ***


Note You need to log in before you can comment on or make changes to this bug.