Bug 740668 - DVDAuthor needs to be rebuild for F16 to work correctly
Summary: DVDAuthor needs to be rebuild for F16 to work correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dvdauthor
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 21:27 UTC by Vaclav "sHINOBI" Misek
Modified: 2011-09-30 19:35 UTC (History)
3 users (show)

Fixed In Version: dvdauthor-0.7.0-4.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-30 18:57:04 UTC


Attachments (Terms of Use)

Description Vaclav "sHINOBI" Misek 2011-09-22 21:27:37 UTC
Description of problem:
When the current version of dvdauthor is used through DVDStyler or manually created menu, the generated DVD has broken buttons. After mock rebuild for F16 it started to work.

Version-Release number of selected component (if applicable):
dvdauthor-0.7.0-3.fc15

How reproducible:


Steps to Reproduce:
1. create DVD with buttons
2. error message regarding Magick
3. buttons at DVD doesn't work
  

Additional info:
Under DVDStyler there was an error, that Magick can't open some png files (files not found), otherwise creation passed without problems.So probably some incopatibility with GraphicsMagick used for compilation??

Comment 1 Ville Skyttä 2011-09-23 16:49:47 UTC
Thanks for the report.  It seems that it's spumux that fails.

GraphicsMagick maintainers FYI: it might be that there have been some incompatible changes in GraphicsMagick between F-15 and F-16 that will require package rebuilds.

Comment 2 Fedora Update System 2011-09-23 16:51:36 UTC
dvdauthor-0.7.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dvdauthor-0.7.0-4.fc16

Comment 3 Rex Dieter 2011-09-23 17:04:01 UTC
GraphicsMagick has only undergone mass rebuilds (perl) since f15, so I'm unaware of anything that could've changed incompatibly there.

any hints or details about the failures alluded-to here?

Comment 4 Vaclav "sHINOBI" Misek 2011-09-23 19:45:09 UTC
Yep, spumux makes the problem. Here is the relevant part of log from DVDStyler.

Menu has 1 group(s) of changeable colours.
Executing command: spumux -P -s 0 "/tmp/dvd-tmp/menu1-0.mpg_spumux.xml"
DVDAuthor::spumux, version 0.7.0.
Build options: gnugetopt graphicsmagick iconv freetype fribidi fontconfig
Send bug reports to <dvdauthor-users@lists.sourceforge.net>
INFO: default video format is NTSC
STAT: 0:00:00.000
Magick: Unable to load file (/tmp/dvd-tmp/menu1-0.mpg_buttons.png) [No such file or directory].
WARN: Bad image,  skipping line -1
INFO: 0 bytes of data written
INFO: 1234944 bytes of data written
INFO: 2469888 bytes of data written
INFO: 3704832 bytes of data written
INFO: 4939776 bytes of data written
INFO: 0 subtitles added, 1 subtitles skipped, stream: 32, offset: 0.16

Comment 5 Ville Skyttä 2011-09-24 05:55:49 UTC
Here's a minimal reproducer:

http://scop.fedorapeople.org/tmp/menu1-1.mpg_spumux.xml
http://scop.fedorapeople.org/tmp/menu1-1.mpg_buttons.png

On a F-15 box with dvdauthor-0.7.0-3.fc15.x86_64 and GraphicsMagick-1.3.12-4.fc15.x86_64, it works:

$ spumux -s 0 menu1-1.mpg_spumux.xml 
[...]
INFO: default video format is NTSC
INFO: Picture menu1-1.mpg_buttons.png had 1 colors
INFO: Picture menu1-1.mpg_buttons.png had 1 colors
INFO: Picture menu1-1.mpg_buttons.png had 1 colors
INFO: Pickbuttongroups, success with 1 groups, useimg=1

But after upgrading GraphicsMagick to 1.3.12-6.fc16.x86_64 it breaks:

$ spumux -s 0 menu1-1.mpg_spumux.xml
[...]
INFO: default video format is NTSC
Magick: Unable to load file (menu1-1.mpg_buttons.png) [No such file or  directory].
WARN: Bad image,  skipping line -1

From that state, if I upgrade dvdauthor to 0.7.0-4.fc16.x86_64 (from koji), it works again.  From there if I leave dvdauthor at 0.7.0-4.fc16.x86_64 but downgrade GraphicsMagick to 1.3.12-4.fc15.x86_64, it breaks similarly again.

Comment 6 Fedora Update System 2011-09-30 18:56:58 UTC
dvdauthor-0.7.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Rex Dieter 2011-09-30 19:35:00 UTC
Ah!  I bet it had to do with the fix for bug #699414

I'll double-check to make sure all other GM-using packages have been rebuilt since then too.


Note You need to log in before you can comment on or make changes to this bug.